Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-06-2010, 08:21 PM   #1
New Member




Join Date: Aug 2010
Location: chicago, illinois, USA
Posts: 23
Newbie seems to have wrong battery pack for SPII MD

Folks -

I'm as new as they come to this group. I've been shooting for many years, almost entirely with Leica & Nikon film cameras (and Canon Digital gear for birding & clients.) However, I've recently procured a coupla M42 bodies & lenses that look like they'll have a bright future in the mix.

Regarding these pieces, I seem to have a Spotmatic II Motor Drive camera with a Motor Drive I but a Battery Pack II (the grip with the batteries has 3 contacts, but the motor drive has 2 on the bottom.)

So, what the heck should I do to get all three components to get along? Rewire the grip? Trade it to someone for a Version I??

Sorry if these are silly questions to those of you with more experience in this Pentax world...

Bob Palmieri

08-07-2010, 08:07 AM   #2
Loyal Site Supporter
monochrome's Avatar

Join Date: Mar 2008
Location: Kirkwood (St. Louis) MO
Photos: Gallery | Albums
Posts: 20,423
Not at all silly, and if anywhere is the place this is it.

As an aside, member smc is looking for a photo of the SPII MD for the camera database. Can you post up a photo of your camera?
08-07-2010, 08:25 AM   #3
New Member




Join Date: Aug 2010
Location: chicago, illinois, USA
Posts: 23
Original Poster
I'm heading to California for a week (and the camera isn't here) but I'll shoot it soon after I get back.

Bob Palmieri
08-07-2010, 09:11 AM   #4
Senior Member




Join Date: Jul 2008
Location: South Carolina, USA
Posts: 276
Out of curiosity I took a gander at Welcome to Bojidar Dimitrov's Pentax K-Mount Page and looked at the Motors section, as afaik the K series bodies and the SPII share a motor drive.

If I'm reading that page right, you've got the wrong battery/power pack, it would seem.

08-07-2010, 09:48 AM   #5
Loyal Site Supporter
monochrome's Avatar

Join Date: Mar 2008
Location: Kirkwood (St. Louis) MO
Photos: Gallery | Albums
Posts: 20,423
QuoteOriginally posted by monochrome Quote
As an aside, member smc is looking for a photo of the SPII MD for the camera database. Can you post up a photo of your camera?
QuoteOriginally posted by snapwell Quote
I'm heading to California for a week (and the camera isn't here) but I'll shoot it soon after I get back.

Bob Palmieri
Thanks - when the database is published (very soon) the membership will appreciate your generosity!
08-07-2010, 09:52 AM   #6
New Member




Join Date: Aug 2010
Location: chicago, illinois, USA
Posts: 23
Original Poster
Yup, that's the way it looks to me, too.

The motor & body seem to be 2 of a kind, but the three-prong battery grip seems to be of a later stripe.

Amusingly, I bought the battery grip attached to the motor (very tightly at that...) as a unit from a seller on ebay...

Bob Palmieri
08-08-2010, 09:42 AM   #7
Pentaxian
Ratmagiclady's Avatar

Join Date: Nov 2008
Location: GA
Photos: Gallery | Albums
Posts: 13,476
Out of curiosity, did you see if the combination works, anyway? It's possible that the third contact is simply redundant with the earlier drive, but still works, unless you know otherwise?
08-15-2010, 09:52 AM   #8
New Member




Join Date: Aug 2010
Location: chicago, illinois, USA
Posts: 23
Original Poster
Not quite working, even after a thorough contact cleaning...

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
battery, battery pack, drive, grip, ii, motor, pack
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Will the FG battery pack JeffJS Pentax Film SLR Discussion 12 03-23-2010 01:48 PM
Does any have this battery pack? bluebronco Pentax Camera and Field Accessories 0 11-06-2009 11:39 AM
Battery for Spotmatic SPII? Brianog Pentax Film SLR Discussion 10 01-03-2009 09:20 PM



All times are GMT -7. The time now is 04:29 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top