Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-12-2010, 08:20 AM   #1
Site Supporter
ismaelg's Avatar

Join Date: Apr 2009
Location: Puerto Rico
Photos: Gallery
Posts: 962
No power up MZ60: Any idea?

Hi,

I have an MZ-60 with the FA 28-80 lens. It doesn't power up even with fresh batteries. I checked and re-checked and ensured the lens in properly attached, it is in A setting, the batteries are fresh and I tested them outside with a multimeter.
I see a very small current drain from the batteries (less than 1 mA) but nothing happens when pressing the power button.
It looks pristine with no signs of abuse, or battery leaks, or water damage or anything like that.
I tested the lens in another camera and it works perfectly fine.
Any idea or suggestion? I know the MZ-60 is not the most desirable camera around and probably not worth sending for repairs but I'd like to try to make it work.
Any idea or suggestion?

Thanks,

09-12-2010, 11:11 AM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 43,280
Have you tried it without any lens on? Isn't the MZ-60 that annoying body which requires F or FA lenses? If so, maybe the electronics that make that check are damaged.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

09-12-2010, 11:21 AM   #3
Site Supporter
ismaelg's Avatar

Join Date: Apr 2009
Location: Puerto Rico
Photos: Gallery
Posts: 962
Original Poster
Thanks Adam.
Yes, I've tried with and without the lens.
This is the only series that only works with F or FA lenses. The FA lens is working properly in both a film (PZ10) and on my DSLR (K100DS).

Thanks,
09-12-2010, 11:55 AM   #4
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 43,280
Then it sounds like something might be broken to me, but I'd try it with yet another set of batteries just to make sure. I made that mistake with an ME F and ended up sending back a completely good camera!


Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

09-22-2010, 09:34 AM   #5
Site Supporter
ismaelg's Avatar

Join Date: Apr 2009
Location: Puerto Rico
Photos: Gallery
Posts: 962
Original Poster
I tried just about everything. Anybody knows how/where to get a service manual?
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
batteries, camera, idea, lens, mz-60, power, suggestion
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Power cord for a TR Power Pack 2 Vern Pentax Camera and Field Accessories 4 12-06-2009 08:13 AM
Any idea?? SteveM General Talk 19 11-16-2009 06:01 PM
Pentax MZ60 problem pentaxing Pentax Film SLR Discussion 6 02-07-2008 11:04 AM
MZ60 battery Question smidsy Pentax Film SLR Discussion 2 11-11-2007 06:07 AM



All times are GMT -7. The time now is 07:17 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top