Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-13-2010, 02:03 AM   #1
Senior Member
pontusadefjord's Avatar

Join Date: Apr 2009
Location: Uppsala
Photos: Gallery
Posts: 111
MX - B not working properly

Hi!

I have an MX that I really love, replaced the light seals and mirror dampers when I got it. There seems to be something weird with the B setting though. All speeds works fine and I don't really use B, but anyway... The shutter doesn't close if the film lever isn't completely "closed". I made a short clip to explain it better...

[YT]http://www.youtube.com/watch?feature=player_profilepage&v=atYCKBt00rs[/YT]

First a couple at 1/30s - nothing wrong here.Then one at B with the lever "closed" - works fine.
Then two with with the lever "open" (not sure what to call it...) - the shutter closes when I push the film lever.

Any ideas what might be wrong? Can I fix it myself?

09-13-2010, 10:12 AM   #2
Inactive Account




Join Date: Aug 2008
Location: Michigan, USA
Photos: Gallery | Albums
Posts: 7,484
Why don't you just make sure the film wind lever is pushed all the way home before pressing the shutter button? As you did in your first example.. Don't know what, if anything is wrong or how you may fix it otherwise.

09-13-2010, 10:30 AM   #3
Senior Member
pontusadefjord's Avatar

Join Date: Apr 2009
Location: Uppsala
Photos: Gallery
Posts: 111
Original Poster
Yes, if I use B I might as well make sure the lever is pushed all the way. Just makes me a bit nervous to think that something might be broken...
09-13-2010, 11:01 AM   #4
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,424
I think your suspicions are probably justified that something is not quite right. Fortunately, whatever is not in adjustment does not seem to be affecting most camera operations. If you decide to get it fixed, the standard advice on this forum is to send the camera to Eric Hendrickson in Tennessee. He does excellent work with reasonable pricing and free estimates.
Eric Hendrickson, Pentaxs.com

Steve

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
film, lever, mx, shutter
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I know if my camera is working properly? Aegon Pentax Film SLR Discussion 15 05-16-2010 10:56 AM
Is my 540 working properly? skystreaker Pentax Camera and Field Accessories 1 04-19-2010 07:19 PM
K20D AF not working properly dgaies Pentax DSLR Discussion 18 03-09-2010 01:15 AM
k1000 light meter not working properly sharko Pentax Film SLR Discussion 10 10-26-2008 11:58 AM



All times are GMT -7. The time now is 08:02 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top