Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-04-2006, 01:52 AM   #1
Junior Member




Join Date: Oct 2006
Posts: 36
My MZ-50

Got my MZ-50 (USA= ZX-5) today. I have to say i am pleasantly surprised. Initially I got a P30, and I saw the MZ-50 for thirty bucks more and thought "hmmm...autofocus, continuous shot, body controlled PASM" but was initially hestitant that it wont work with non A lenses. Well, the verdict is that although it wont work with my SMC M 50mm and Zenitar , it *did* work with my M42 screw mount lenses in Av (and M) mode, contrary to internet literature!! I Confirmed this with my K100D on spot metering, Av, identical ISO - the two cameras yielded identical Shutter speeds, and turning the aperture ring does indeed change the shutter speed correspondingly

Next thing is to go out and do a test roll. If all goes well I think my P30 will be returned to the good old ebay pool w/ my M lenses to raise funds for a 50mm AF 1.7 =). but on the other hand, it does make a neat backup body with some of the MF primes

12-05-2006, 03:42 AM   #2
Veteran Member




Join Date: Sep 2006
Location: Melbourne, Australia
Posts: 423
Not too sure if you have made a typo but:
MZ-50 = ZX-50
MZ-5 = ZX-5

cheers
Kenny
12-06-2006, 07:33 AM   #3
Veteran Member
Nesster's Avatar

Join Date: Oct 2006
Location: NJ USA
Photos: Gallery
Posts: 13,047
Thanks for the info - I have the ZX-50 and I've been wondering about just that, it's good news about the M42 mount, good news indeed! What adaptor are you using?

In case you're wondering (probably not) the body works great with a Lensbaby


On further thought - when you change aperture, the lens stops down... the viewfinder gets darker? or vice versa, when opening the aperture?

That is, the M42 lens works in 'stop down' mode? Ie. if you want to focus wide open, you'd first set the aperture to wide open, and then stop down to the desired taking aperture. The camera will meter correctly based on that.

Or is there something else going on....

Last edited by Nesster; 12-06-2006 at 10:09 AM.
12-06-2006, 09:15 PM   #4
Junior Member




Join Date: Oct 2006
Posts: 36
Original Poster
hiya Nesster,

I'm just using one of those M42 - K ring adapters from ebay, ie no electrical contacts. And the lenses I'm using are stop down metering ones (ie viewfinder goes dark), tested with takumar 28mm, on Aperture priority mode.

I think i have to wait for my first roll to get processed and post it up b4 im sure it works

03-09-2007, 08:43 AM   #5
New Member




Join Date: Mar 2007
Location: Brazil
Photos: Gallery
Posts: 3
I have a MZ-50 too! I love her!!!

See more in:

https://www.pentaxforums.com/forums/pentax-film-slr-discussion/715-processing...html#post34595

Hugs from Brazil!

Themeron
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
50mm, av, body, lenses, mz-50, p30, shutter
Thread Tools Search this Thread
Search this Thread:

Advanced Search



All times are GMT -7. The time now is 08:55 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top