Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-23-2010, 04:30 PM   #1
Pentaxian
Swift1's Avatar

Join Date: Sep 2009
Location: Oregon
Photos: Gallery | Albums
Posts: 3,808
SPII Meter. Need Help.

I recently picked up a Spotmatic SPII. It came with no battery (not very surprising), so after a bit of looking, I found a Varta V392 1.5v battery. The battery fits rather loosely but it does fit. When I switch the meter on, the needle just goes about 3/4 of the way to the top and stays there no matter what aperture/shutter/iso combo.
Is the meter shot or is this a battery problem?
The first time I put the battery in I put it in upside down and the meter did the opposite, i.e. the needle went down instead of up.

Any help is much appreciated,

11-24-2010, 06:35 PM   #2
Loyal Site Supporter
Canada_Rockies's Avatar

Join Date: Nov 2007
Location: Sparwood, BC, Canada
Photos: Gallery | Albums
Posts: 9,144
I don't think that is the correct replacement battery. The battery should fit snugly. In case I'm mistaken (not the first time) use a pencil eraser to clean the battery chamber contacts thoroughly.
11-24-2010, 06:36 PM   #3
Veteran Member




Join Date: Mar 2007
Location: Christchurch, New Zealand
Photos: Gallery
Posts: 433
Colton,

Your problem could come down to the fact that Spotmatic II cameras are designed to use a 1.3V cell, where as you are trying to use a 1.5V cell. This will much up the electronics of the metering.

I'd suggest that you search battery suppliers on the Internet or eBay for appropriate 1.3V batteries.

Also see the camera review section of this website for more details of what sort of battery is appropriate for which camera.

Regards

Chris Stone
11-24-2010, 07:36 PM   #4
Pentaxian
Swift1's Avatar

Join Date: Sep 2009
Location: Oregon
Photos: Gallery | Albums
Posts: 3,808
Original Poster
I have read on various sites that this battery should work, but it may be wrong.
I ordered a Wein Cell for it so hopefully that will work.

11-25-2010, 09:20 PM   #5
Veteran Member
Stratman's Avatar

Join Date: Mar 2007
Location: St Louis, Missouri U S A
Photos: Gallery | Albums
Posts: 2,464
I use an Energizer 392 in my Spottie SP II, and SP 1000 and all is well, works just fine. I did get a small o-ring to help keep the battery centered in the compartment....
11-25-2010, 10:14 PM   #6
Site Supporter




Join Date: May 2010
Location: melbourne
Posts: 934
I've got an SP 11 & 1.5v batteries work fine.
Don't know what your actual problem is, but maybe if you placed some sort of stuff, tape etc around the battery to keep it in a central location, it may work properly.....there are lots of battery threads on this forum.
Cheers, Pickles.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
battery, meter, needle, spii
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trying to date my SPII Steve Ingram Pentax Film SLR Discussion 4 11-08-2009 05:49 PM
Repair Asahi SPII My Light Meter 3RiC Pentax Film SLR Discussion 3 11-02-2009 12:14 AM
Asahi SPII My Light Meter Isn't Working. Cameron030293 Pentax Film SLR Discussion 7 10-13-2009 06:46 AM
My SPII yosemitesamiam Pentax Film SLR Discussion 25 01-10-2009 02:00 PM
Spotmatic SPII memma Pentax Film SLR Discussion 13 07-12-2007 11:07 PM



All times are GMT -7. The time now is 12:02 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top