Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-31-2011, 09:25 PM   #1
New Member




Join Date: Jan 2011
Location: new york
Posts: 1
Broken film advancer

I have a honeywell pentax spotmatic sp II and the film advancer seems to be broken. When there is no film in the camera, it looks like it is working- when I pull back on the lever, the spool turns as it should. When I put film in there however, it seems as though the lever isn't strong enough to pull the film. It might move a tiny put at the beginning but peters out after a notch or two. can this be fixed? also the light meter doesn't work even after i put in a new battery. I don't really care about that though, i just added that fact in case it helps solve the problem.

01-31-2011, 10:30 PM   #2
Pentaxian




Join Date: Sep 2007
Location: Bay Village, Ohio USA
Posts: 1,027
Rewind Button?

Is the rewind button on the bottom of the camera pushed in? This may have somehow gotten stuck. The symptons you describe sound like what happens when the rewind button is pushed in. BTW, this is how you can deliberately make a double exposure. Take the first pic, push the button, cock the shutter while holding the button down, take the second pic, advance the film after releasing the button. It is best to advance another frame, because the film advance often doesn't "catch" until halfway through the advance.

If the rewind button is stuck, I'm not sure what you can to do correct it. It might pop back up, with a little help and begin working again. If not, something inside is probably broken or bent.

Good luck. Spotmatics are great cameras.
02-01-2011, 02:06 PM   #3
New Member




Join Date: Mar 2010
Location: Texas
Posts: 5
That sounds an awful lot like an issue I have with one of my Spotmatic bodies. I ended up having to get another on ebay...still have the first one though. Does any of this sound like your problem?

The trouble started after my brother used the camera. Apparently, the film wasn't advancing smoothly and he forced the lever. (It was Dad's camera at the time, otherwise there would have been vengeance.) Now, the film only advances a partial frame per exposure so the only way to use it is to cover the lens and click+advance several times. The amount of slippage is not consistent. So sometimes it will advance a full frame, sometimes a half, sometimes less.
02-01-2011, 02:26 PM   #4
Veteran Member
pixelsaurus's Avatar

Join Date: Jul 2007
Location: Levin, NZ
Photos: Gallery | Albums
Posts: 778
QuoteOriginally posted by Mrelia Quote
Now, the film only advances a partial frame per exposure so the only way to use it is to cover the lens and click+advance several times. The amount of slippage is not consistent. So sometimes it will advance a full frame, sometimes a half, sometimes less.
It is possible that there may be damaged or stripped cogs in the winding mechanism. Apparently Spotmatics were a repair techies dream so if you are so inclined, you may be able to repair it. Thomas Tomosy, in the 90's, put out some repair manuals: "Camera Maintenace & Repair" in 2 volumes. There are fairly generic but do include Pentax film models. They may be available through Amherst Media or a really good library.Good luck.

02-02-2011, 11:08 AM   #5
New Member




Join Date: Mar 2010
Location: Texas
Posts: 5
Thanks for the recommendation! I've requested a copy of Volume 1 on interlibrary loan to get started. Since I have two camera bodies, I have no qualms about trying a bit of fixerupping.
02-02-2011, 02:07 PM   #6
Veteran Member
pixelsaurus's Avatar

Join Date: Jul 2007
Location: Levin, NZ
Photos: Gallery | Albums
Posts: 778
QuoteOriginally posted by Mrelia Quote
I've requested a copy of Volume 1 on interlibrary loan to get started.
Pages 92 -95 for the Spotmatic. The first 14 chapters deal with tools, DIY test equipment and troubleshooting. You may want to get hold of Book 2 as well, Chapter 5 is on repair of mechanical components. Have fun.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
advancer, film, lever
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lens is broken: broken mount nemo9439 Pentax SLR Lens Discussion 4 08-27-2010 09:52 AM
Newbie SLR film and film develop qestion winglik Pentax Film SLR Discussion 11 06-15-2009 03:13 AM
Broken dreams, broken camera brkl Post Your Photos! 3 03-10-2009 05:08 PM



All times are GMT -7. The time now is 06:39 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top