Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-05-2011, 02:02 PM   #1
New Member




Join Date: Feb 2011
Posts: 1
Pentax Me Problem

hi

i have recently found my father's old Pentax ME in the garage and have been trying to get it to work for a while. when i first picked it up, everything seemed to be in working order, the advance lever moved well, light meter operated. i then tried to put some 35mm film in, not knowing what i was doing i stupidly pressed the rewind button. this is now stuck in this position, meaning i cant advance film into the camera.

i checked up on several forums to see what the problem might be, with one saying it was just jammed. i removed the bottom cover to see if it had, didnt want to touch anything. when i did open it, a small piece of metal black metal feel out, which i assume was mechanical as it has rub marks on one end but i cant see where i has broken off from . i will upload photos of the camera and broken piece when i get my other camera back. otherwise is there anything i can do to get the rewind button back to i's normal position?

thank you for your help

Rozza

02-05-2011, 03:22 PM   #2
Veteran Member
fotaki's Avatar

Join Date: Aug 2008
Location: Greece and UK
Photos: Gallery | Albums
Posts: 309
It would seem that something is definately amiss and if I were you would not attempt a repair yourself - even if you could find out the problem. Besides, the camera is of an age that it would benefit from a little care and attention. I suggest you send it to a specialist for repair and overhall.

I see from your profile you are in England. There are a few good repair shops in the UK such as -

BLACK ON WHITE
The Photographic Repair Shop
105 Coldharbour Road
Westbury Park
Bristol
BS6 7SD

Tel: 0117 942 0434
Fax: 0117 907 1135
____________________________

Sendean Cameras
22/23 St Cross Street
Hatton Garden
Clerkenwell
London EC1N 8UH

tel: 0844 357 1414*

email: mail@sendeancameras.com
___________________________

Harrow Technical
Pentax House
South Hill Avenue
South Harrow
Middlesex, HA2 0DU

Tel: 020 8938 4660
Fax: 020 8938 4605

E-mail: info@harrowtechnical.co.uk

I've had good service and can recommend this last address.

PS. All three addresses have websites if you do a search
02-05-2011, 06:37 PM   #3
Pentaxian
ChrisPlatt's Avatar

Join Date: Nov 2007
Location: Queens NYC
Posts: 4,858
The rewind button will normally be released only when you operate the film advance.
The film advance cannot be operated until you fire the shutter. Have you tried that?

Chris

Last edited by ChrisPlatt; 02-05-2011 at 07:30 PM.
02-06-2011, 07:55 AM   #4
Site Supporter
Sluggo's Avatar

Join Date: Sep 2006
Location: Ames, Iowa
Photos: Gallery | Albums
Posts: 601
Just to add to what Chris said above, I suggest first setting the control dial to 100x. Then try to fire the shutter and advance the winder. Hopefully the rewind button will pop.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
advance, button, camera, cant, film, metal, pentax, piece, position, rewind
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax MX - Do I have a problem? spock999 Pentax Film SLR Discussion 7 01-27-2011 08:00 AM
Help - Pentax Kx problem armrob Pentax DSLR Discussion 8 12-30-2010 06:32 AM
K-5 battery problem? camera problem? user problem? imtheguy Pentax K-5 39 11-03-2010 06:02 PM
problem with pentax pz-1 / z1 molotvo Pentax Film SLR Discussion 6 12-20-2009 11:01 PM
Card read problem K20d. Have you had this problem? rsi1986 Pentax DSLR Discussion 8 12-27-2008 05:25 AM



All times are GMT -7. The time now is 01:15 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top