Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-12-2007, 10:34 PM   #1
New Member




Join Date: Mar 2007
Location: Los Angeles
Posts: 15
Follow-up on 645NII package.

I saw all the items today and tried everything at a camera repair store, where I had the party drop it all off for trial. Lenses all very little wear, clean and functioned with camera fine. 2-backs very little wear. Adaptor some wear but fits fine. Camera very clean and very low wear. During camera testing, the camera shut down a number of times. Lost power so that the LCD went off and then after anywhere from several seconds to 1 or 2 minutes, power came back on by itself. Camera had several older lithium batteries mixed in with another brand of lithium I think. Seller said he hasn't used camera in 2 years when it worked fine. Low battery indicator didn't come on at anytime, but I see in instructions that Pentax says "don't mix brands or old with new, replace all at same time". Anything thoughts on this. Could the mixing of batteries actually do this? He is willing to come down in price somewhat because of the potential of repair. Estimate $200-400 by repair shop, IF SOMETHING IS ACTUALLY WRONG. Everything else worked fine, exposure and focus. He originally wanted $700. might come down to 450. or 500. which would cover me in case I really do need repair.
So, what do you think??
Thanks for you advice.
Jonathan

10-12-2007, 11:04 PM   #2
New Member




Join Date: Mar 2007
Location: Los Angeles
Posts: 15
Original Poster
Follow-up on 645NII package.

By the way, when we tried the camera, we did not have the rear body cap installed if this makes any difference-but we did try it with the 120 insert on.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
batteries, camera, lithium, power, repair, wear
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Just got a 645NII... OOPS! mikebob Pentax Medium Format 13 04-25-2010 04:33 PM
Pentax 645NII Ole Pentax Medium Format 0 06-13-2009 07:53 PM
How is this price for a 645NII package? jljonathan Pentax Film SLR Discussion 9 10-16-2007 06:08 PM
Now, dead 645NII question jljonathan Pentax Medium Format 3 10-14-2007 03:53 AM



All times are GMT -7. The time now is 07:48 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top