Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-16-2011, 03:57 PM   #1
Veteran Member




Join Date: Jan 2008
Location: Southern California, USA
Photos: Gallery
Posts: 730
Need help! Super Program's NOT working shutter control.

I have an old Pentax Super Program.
Recently my friend borrowed this for her photography class.
Right now, I can't get to change the shutter speed anymore when switched to M mode.
Somehow, the top LCD display only show 1000 (sometimes) or nothing at all.
It's not dead yet because it still show 125x or B when I switch to those modes.

I've tried to take off the lens (A 50mm 1.7) and re-mount it again but it doesn't do anything.
It worked for a few second where I can adjust the shutter speed and see the exposures compensation through the viewfinder lcd but then it went dead again.
Now it doesn't show anything anymore.

Anybody can please give me advice on how to fix this problem?
Is my Super Program totally broken?
I really hope I can fix it myself.

Thanks in advance.

03-16-2011, 03:59 PM   #2
Site Supporter
boriscleto's Avatar

Join Date: Dec 2009
Location: Liverpool, NY
Photos: Gallery
Posts: 12,872
Have you tried fresh batteries? The Super Program doesn't function at all without batteries.
03-16-2011, 04:04 PM   #3
Veteran Member




Join Date: Dec 2007
Location: Prague
Photos: Gallery
Posts: 1,198
Is film loaded? Perhaps you pushed the button on bottom accidentally. Fire three blank shots and it should continue working again.
03-16-2011, 04:09 PM   #4
Veteran Member




Join Date: Jan 2008
Location: Southern California, USA
Photos: Gallery
Posts: 730
Original Poster
QuoteOriginally posted by boriscleto Quote
Have you tried fresh batteries? The Super Program doesn't function at all without batteries.
QuoteOriginally posted by elho_cid Quote
Is film loaded? Perhaps you pushed the button on bottom accidentally. Fire three blank shots and it should continue working again.
Hmm..good suggestions. I haven't changed the battery since my friend borrowed it.

Elho_cid, I'll try this when I get home tonight.

Thanks, guys. Hopefully it will come back alive again.

03-16-2011, 05:55 PM   #5
Veteran Member
GerryL's Avatar

Join Date: Jan 2009
Location: CA
Posts: 2,731
QuoteOriginally posted by elho_cid Quote
Is film loaded? Perhaps you pushed the button on bottom accidentally. Fire three blank shots and it should continue working again.
I agree with this, wind and fire the camera until it reaches counter "1" or "0" (I forgot) because, the super program/super-A stays at the speed of "1000" so that it will easily reach the first frame and not "meter" before the first frame.
Reasoning behind this is, if it "meters" immediately and you have the cap on the lens or it is dim, then the shutter wouldn't be as fast and going into the first frame to set up for your first shot would take a longer time rather than just firing 3 fast (blank) shots.
"B" (bulb) setting wouldn't also work if camera lens is set to "A", as I recall, the aperture lens should be opened and not locked to "A".
03-16-2011, 08:52 PM   #6
Veteran Member




Join Date: Jan 2008
Location: Southern California, USA
Photos: Gallery
Posts: 730
Original Poster
Problem solved.
After I wind & fire until the counter reaches 1, I can adjust the shutter speed again.
Thank you for the helps, guys.
03-18-2012, 08:52 PM   #7
New Member




Join Date: Mar 2012
Posts: 3
Awesome, so glad to find this info. I was about to pull my hair out! I even signed up and was about to pose this same question before a quick search found the answer.

I had searched the interwebs far and wide for an answer to this issue - and some of the results even led me to this site, though not this particular post. That said, I'll throw a few keywords in for good measure so that the next person with this issue won't have to search so hard:

Pentax Super Program shutter speed problem
Pentax Super Program shutter speed stuck at 1000
Cannot change shutter speed on Pentax Super Program

I'll be posting some pics soon from my pristine new (old) Pentax!
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
lcd, program, shutter
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Remote Shutter Control KidLogic Pentax DSLR Discussion 8 11-30-2010 07:59 AM
remote control not working geckogrin Pentax DSLR Discussion 5 09-22-2010 07:40 PM
Help! MZ-7 shutter release not working Black Magic Pentax Film SLR Discussion 9 08-12-2009 08:56 AM
P30T, shutter will not reliably stay open on bulb with cable shutter control. skid2964 Pentax Film SLR Discussion 6 06-09-2008 08:04 AM



All times are GMT -7. The time now is 03:13 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top