Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-27-2011, 03:34 AM   #1
Senior Member




Join Date: Jan 2007
Location: Bristol, England
Photos: Gallery
Posts: 108
MZ-M (ZX-M) very premature rewind

I have just given an old MZ-M to a friend and typically he has immediately got a problem I don't remember seeing before.

Before I gave it to him I just finished up an ancient film in it. I rewound fine. I told him I didn't know the state of the battery, so he has replaced it.

On loading a film (I wasn't there, so I don't know if he did anything wrong) it wound on to "1" then immediately rewound.

Any ideas whether it might be user error (what could it be) or a problem with the camera?

Thanks

04-29-2011, 03:07 AM   #2
Veteran Member




Join Date: Jan 2010
Location: Ferguson, Mo.
Photos: Gallery
Posts: 1,348
Happen twice in app. 14 years of use with mine Simon.Had CR2 lithiums installed.
Has never happened since I picked up battery grip (FG) and used with required AA
cells(4),either alkaline or lithium.Assumed CR2's were in fully charged state when
bought,didnt verify..Did try to 'dig' leader out of canister to try and re-shoot
wasnt able to grab either without damage.Film is still a little suspect, though
it hasnt happened again since BG(FG) was added.
05-03-2011, 08:19 AM   #3
Senior Member




Join Date: Jan 2007
Location: Bristol, England
Photos: Gallery
Posts: 108
Original Poster
Thanks BillM.

Since my original post I've got my last film back from the camera (before I gave it away) and found that the last few frames suffered a wind-on problem - they overlap slightly. I guess either:

- The film had got sticky having been in the camera for some time,
- The camera wind-on had got a bit sticky, which may or may not sort itself out (or need a service) or
- The wind cog had (as sometimes reported) got brittle and failed when I took the camera out of "moth balls"

I will see how my friend got on with a second attempt to load the camera, and maybe recommend a service - which might not be economic on a camera I just gave him (he's on a fairly tight budget).

Thanks

Simon
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
film, mz-m, rewound
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rewind Shaft EricTn Pentax Film SLR Discussion 4 11-07-2010 04:41 PM
Missing lever on MX rewind knob QuixoticTonic Pentax Film SLR Discussion 6 01-16-2010 01:41 AM
Film rewind problem MeFirstO Pentax Film SLR Discussion 17 07-15-2009 11:26 PM
Help! Spotmatic rewind trigger stuck! drewdlephone Pentax Film SLR Discussion 4 06-23-2009 06:13 PM
K100 has premature 'Low Battery Indication/ shut down" seriousam Pentax DSLR Discussion 19 07-09-2007 08:36 AM



All times are GMT -7. The time now is 08:13 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top