Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-09-2011, 04:00 AM   #1
Senior Member




Join Date: Jul 2009
Location: Thornbury, England
Photos: Gallery
Posts: 181
ME Super Film Advance Problem

I was using my ME super the other day and noticed that I could advance the film without taking a shot.
The advance indicator was working and all appeared ok when rewinding the film (just sent film for processing).

Has anyone got any ideas what might be wrong?

Thanks in advance for any help.

06-09-2011, 09:39 AM - 1 Like   #2
Veteran Member




Join Date: Feb 2011
Location: Philly
Posts: 380
The only thing I can think of is to take off the plate and see if the wind lock is bent or anything like that. Check out this page:

Favorite Classics > Pentax ME Super Ramblings > Three Common Failure Problems

Especially the part I bolded in red.

QuoteQuote:
Three common failure problems of the ME Super come to mind:
1. Over zealous winding
A. Winding too hard, especially at the end of the wind stroke, can shear off the tab shown below. If this is the problem the wind lever will move freely until it wedges into the other components under the frame counter plate.
And… you’ll be in for some serious disassembly.

B. Winding too hard when the wind lock isn’t released will bend the wind lock catch. You’ll know it is bent if the wind lever can be wound, then wound again without releasing the shutter. But luckily it can usually be bent right back in position without permanent damage.

06-09-2011, 12:24 PM   #3
Senior Member




Join Date: Jul 2009
Location: Thornbury, England
Photos: Gallery
Posts: 181
Original Poster
Many thanks
All back together and good as new (ish)
06-09-2011, 02:55 PM   #4
Veteran Member




Join Date: Feb 2011
Location: Philly
Posts: 380
No problem. I had to use that site many times when I got my ME Super to return it to service.

06-15-2011, 03:26 AM   #5
Pentaxian
titrisol's Avatar

Join Date: Dec 2007
Location: In the most populated state... state of denial
Photos: Gallery | Albums
Posts: 1,094
The wind lock is the semi-circular piece in the back-top-left.. right?


That is the one that must be re-bent?
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
advance, film, film advance
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K1000: Problem with film advance summernolan Troubleshooting and Beginner Help 7 04-14-2011 12:39 AM
Film Advance issues- ME Super halfpack Ask B&H Photo! 3 06-01-2010 07:19 AM
Film Advance issues- ME Super halfpack Pentax Film SLR Discussion 4 05-29-2010 09:20 AM
Super Program problem with film advance and shutter release Laurie60014 Pentax Film SLR Discussion 6 07-18-2008 09:00 PM
ME Super film advance lever problem! Thursday Pentax Film SLR Discussion 8 09-12-2007 12:07 AM



All times are GMT -7. The time now is 09:21 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top