Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-03-2015, 05:07 PM   #4441
Pentaxian
45 Mike's Avatar

Join Date: Feb 2014
Photos: Albums
Posts: 1,347
QuoteOriginally posted by Niner Alpha Quote
I got a Petri 7S recently. Paid $10 for it and discovered it had been dropped... from a high place apparently...and not onto a forgiving surface. Focus adjustment was hard because the track had been jarred out of joint. The film advance was problematic and required a little pocketknife blade prying to advance at first. The shutter worked and the various apertures seemed ok and connected to the controls. Then I got the camera going satisfactorily. The selenium meter seemed to be the only thing still working on it's own from the get go. Then I put in a a roll of Kentmere 100 ...all 36 exposures and went outside to try it out. I got ten exposures into the roll and then everything locked up ...except the light meter. I got the focus ring to work but the film advance was stuck and stuck good. I did develop the film. And... too bad it's now a paper weight. The lens seemed to be pretty decent for a relic of the past.
That is sad, but fairly common for the old inexpensive cameras. Used hard, abused, set aside, then sold on ebay, or whatever.

12-03-2015, 09:40 PM   #4442
Forum Member
Niner Alpha's Avatar

Join Date: Oct 2015
Posts: 73
I just bought another one.... just to see if it works or not. It can't be in worse shape than the last. ....I don't think.
12-04-2015, 10:47 PM - 7 Likes   #4443
Pentaxian
g026r's Avatar

Join Date: Sep 2013
Location: Toronto
Photos: Gallery
Posts: 1,348
First roll back from the Flexaret II. (And only one frame where I forgot to advance before firing the shutter!)

A few sample shots, all on Acros, with the first cropped a little:





12-05-2015, 01:09 AM   #4444
Pentaxian
Jonathan Mac's Avatar

Join Date: Apr 2009
Location: Madrid, Spain
Posts: 4,115
QuoteOriginally posted by g026r Quote
First roll back from the Flexaret II. (And only one frame where I forgot to advance before firing the shutter!)

A few sample shots, all on Acros, with the first cropped a little:





Very nice indeed.

12-05-2015, 03:50 AM   #4445
Pentaxian




Join Date: Nov 2013
Location: North Bohemia
Photos: Gallery
Posts: 1,095
Yes! Wow. It's a Czechoslovakian camera
12-05-2015, 11:27 AM   #4446
Pentaxian
bobbotron's Avatar

Join Date: Jan 2015
Location: Ottawa, ON
Photos: Gallery
Posts: 1,865
QuoteOriginally posted by Niner Alpha Quote
I just bought another one.... just to see if it works or not. It can't be in worse shape than the last. ....I don't think.
I hope it works! I love how quiet the shutter is on mine, I almost thought mine wasn't working at first it's so quiet and quick.

The film take up spool is nearly impossibly slippery, it's a real pain to load.
12-07-2015, 01:03 PM   #4447
Forum Member
Niner Alpha's Avatar

Join Date: Oct 2015
Posts: 73
QuoteOriginally posted by bobbotron Quote
I hope it works! I love how quiet the shutter is on mine, I almost thought mine wasn't working at first it's so quiet and quick.

The film take up spool is nearly impossibly slippery, it's a real pain to load.
It came in the mail today. Light meter isn't working right. Strange noise when advancing the cocking-advance lever. But.... shutter speeds and apertures seem more or less right. I'll be trying it out soon.
Attached Images
View Picture EXIF
PENTAX Optio W20  Photo 
12-07-2015, 01:55 PM   #4448
Pentaxian
bobbotron's Avatar

Join Date: Jan 2015
Location: Ottawa, ON
Photos: Gallery
Posts: 1,865
QuoteOriginally posted by Niner Alpha Quote
It came in the mail today. Light meter isn't working right. Strange noise when advancing the cocking-advance lever. But.... shutter speeds and apertures seem more or less right. I'll be trying it out soon.

They are nice looking cameras. I like mine, definitely something different from my army of mechanical Pentax SLRs.

12-07-2015, 06:18 PM - 5 Likes   #4449
Senior Member




Join Date: Apr 2015
Location: Pensacola Florida
Photos: Gallery
Posts: 129
My favorite shot from a local car show last week. I meant to over develop in D-76 by 20% but forgot that I had Ilford HP5 400ISO instead of Ilford Delta 400ISO. I think I ended up developing around 40% extra time by mistake. This scan was run through a Photoshop and NIK plugins, to make it look more like the print I made on fiber paper. In the printing class we were using two developers. Two minutes in Dektol at 1:20(dektol:water) for the highlights and 30 seconds in a 1:2(dektol:water) for the shadow detail. Scanning prints seems like a waste, at least with my scanner.

Canon A-1 75-200mm, Ilford HP5 400, D-76 1:1 @ ~17minutes. Epson V550.
12-07-2015, 07:34 PM - 3 Likes   #4450
Pentaxian
vinceloc's Avatar

Join Date: Jul 2007
Location: Philippines
Photos: Gallery
Posts: 352
Games children play...



Rustic life...



Stil waters...


Pentax KX + ACROS100
12-07-2015, 09:01 PM - 1 Like   #4451
Forum Member
Niner Alpha's Avatar

Join Date: Oct 2015
Posts: 73
Bought a box full of point and shoot camera's for cheap to take on singular photo shoot adventures just to see what they would do. One is a Pentax IQzoom EZY-80. Lots of name for a simple camera. This is from last week.

If you are wondering... a Sago Palm. I forgot to turn off the date thing. Notice the year.



Last edited by Niner Alpha; 12-07-2015 at 09:04 PM. Reason: free image uploads ran out. No problem
12-08-2015, 06:34 AM - 2 Likes   #4452
Veteran Member
Nesster's Avatar

Join Date: Oct 2006
Location: NJ USA
Photos: Gallery
Posts: 13,047




June 2008, BW400CN, Fed-3, Jupiter-8M
12-08-2015, 11:59 AM - 2 Likes   #4453
Senior Member




Join Date: Nov 2010
Location: Nova Scotia, Canada
Posts: 251
XP2 @200, Rodinal 1+100 for one hour:























12-08-2015, 12:29 PM   #4454
Pentaxian
bobbotron's Avatar

Join Date: Jan 2015
Location: Ottawa, ON
Photos: Gallery
Posts: 1,865
QuoteOriginally posted by drmoss_ca Quote
XP2 @200, Rodinal 1+100 for one hour:























Very cool. Until recently I didn't realize you could process XP2 in normal BW chemicals!
12-08-2015, 01:30 PM - 2 Likes   #4455
Site Supporter
chickentender's Avatar

Join Date: Jan 2008
Location: Seattle, WA
Photos: Gallery | Albums
Posts: 1,987
some b&w from a magic morning last week... P645Nii | SMC-67 75/4.0 | HP5 Plus | V750 scan





---------- Post added 12-08-15 at 12:54 PM ----------

QuoteOriginally posted by g026r Quote
First roll back from the Flexaret II. (And only one frame where I forgot to advance before firing the shutter!)

A few sample shots, all on Acros, with the first cropped a little:





Lovely ones there. I've been eyeing a Flexaret for close to a year now.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
autofocus, camera, d-76, dog, doubt, exposure, film, flickr, fp4, kiev, leak, lens, love, mine, minutes, nikkormat, pentax, phil, photography, pm, post, quality, roll, shot, shots, smc, sp500, station, steve, thanks
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Travel Some B&W film shots from the Gulf of Gaeta, Italy Rense Post Your Photos! 3 04-23-2011 12:22 AM
First post - few b&w shots sealisthenewbeaver Photo Critique 2 09-22-2008 06:40 PM
My Pentax shots in print & film. blwnhr Photographic Technique 5 03-18-2008 05:13 PM
First shots with a zx-5 film camera (c&c welcome) jbrowning Post Your Photos! 2 12-23-2007 08:18 AM



All times are GMT -7. The time now is 12:36 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top