Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-02-2012, 08:11 PM   #1
Inactive Account




Join Date: Aug 2011
Posts: 10
broken lightmeter?

Hi all. I just went to shoot today with my Pentax ME super, after a couple of nice shots (with the light meter behaving fine)
I decided to take some shots ontop of a tower, my light meter was unable to read the correct exposure and the read light for over would flash up.
I then got off the tower and walked around, my LED's seemed feint and my camera would not give me the correct exposure for anything.. I tried changing my ISO dial as im shooting 200 iso film on an overcast day but my camera was still unable to read the exposure. I haven't replaced the batteries for a while, could it be as simple as that?
I did some test shots inside as i was able to get a reading, my camera read 125 and i took a photo and my shutter stayed open for something like 2 seconds, it was strange.

any help or advice would be appreciated.. I have some new batteries at home so i'm going to give them a try later tonight

07-02-2012, 08:26 PM   #2
Veteran Member
KungPOW's Avatar

Join Date: Nov 2007
Location: Vancouver, Canada
Photos: Gallery
Posts: 1,702
Replace the batteries.
07-02-2012, 08:33 PM   #3
Inactive Account




Join Date: Aug 2011
Posts: 10
Original Poster
thanks! i was hoping it would be something as simple as that.
07-05-2012, 02:43 AM   #4
Veteran Member
goddo31's Avatar

Join Date: Feb 2009
Location: Perth, Western Australia
Photos: Gallery | Albums
Posts: 2,295
"my LED's seemed feint and my camera would not give me the correct exposure for anything.. "

Yep, that sounds like flat batteries to me.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
batteries, camera, exposure, iso, light, meter, read, shots, tower
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
6x7 lightmeter not working smurley Pentax Medium Format 7 03-26-2012 04:53 PM
For Sale - Sold: Takumar F 70-200/Yashica M42 135/2.8/Fujix Hi8/broken SONY Hi8/broken Canon G2 benhai Sold Items 8 03-19-2012 11:54 AM
M-mode lightmeter problems on K-5 debbie Pentax K-5 4 11-26-2011 11:50 AM
Lightmeter ESII Hilo Pentax Film SLR Discussion 5 09-13-2011 07:27 AM
Lens is broken: broken mount nemo9439 Pentax SLR Lens Discussion 4 08-27-2010 09:52 AM



All times are GMT -7. The time now is 06:59 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top