Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-23-2012, 10:54 AM   #1
Site Supporter
Eric Auer's Avatar

Join Date: Jul 2012
Photos: Albums
Posts: 861
Shutter Issues with a K1000 SE...

Ok so for some reason my trusty old K1000 SE no longer opens the shutter at 1000 and 500....

All other speeds are fine.

Anything I can do myself or do I need to pony up for a CLA?

Alternatively I could just retire it, It had a good long run.

It always looked good on Display, Nice brown leatherette and all.

09-23-2012, 11:31 AM   #2
Pentaxian
arnold's Avatar

Join Date: Aug 2012
Location: Queensland
Photos: Gallery | Albums
Posts: 3,295
I'm in a similar situation with a shutter that fires before the mirror goes up. You may be able to lube your way out of it, by removing the bottom plate and checking a Spotmatic thread here (don't have the link handy) about a sticking mirror and a YouTube link to where to lube.
09-23-2012, 11:35 AM   #3
Pentaxian
Swift1's Avatar

Join Date: Sep 2009
Location: Oregon
Photos: Gallery | Albums
Posts: 4,000
If you still shoot film and have been using it, I would get it CLA'd.
Unless you replace it with a CLA'd camera, chances are that any replacement body probably needs a CLA anyways.
You could spent the $65-$85 a CLA would cost and get a reliable camera that you know and has used, or spend $25-$75 for a replacement K1000 SE and then quite possibly have to get a CLA anyways.
09-23-2012, 11:56 AM   #4
Site Supporter
Eric Auer's Avatar

Join Date: Jul 2012
Photos: Albums
Posts: 861
Original Poster
Thanks guys I have so many other film bodies that I'll probably just let this one alone unless I can find a DIY way to fix it.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
k1000, shutter, shutter issues
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K1000 Shutter trip technique arnold Troubleshooting and Beginner Help 13 11-15-2012 09:17 PM
ME Super Shutter Speed Issues camrnw Pentax Film SLR Discussion 8 07-09-2012 11:27 AM
issues with my k1000 elevatormusic Troubleshooting and Beginner Help 8 12-02-2011 09:17 PM
K1000's faulty shutter at 1/1000 jzietman Pentax Film SLR Discussion 7 12-30-2010 02:22 PM
K1000 shutter button not working?! jzietman Pentax Film SLR Discussion 2 11-01-2010 09:41 PM



All times are GMT -7. The time now is 12:38 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top