Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-25-2012, 10:42 PM   #1
New Member




Join Date: Oct 2012
Posts: 4
Pentax ME shutter speed vs meter issue

Hi!

New forum member here. I've just acquired an ME (not super) in great condition inside and out. However, I've noticed something very strange. It seems that the automatic shutter speed selection gets "locked" at whatever the meter indicates when I cock the shutter. For example, if I happen to cock the shutter when the meter reads 1/1000, then point the camera at something dark and the meter indicates 1 sec, the camera will still fire at 1/1000, This does not seem like it should be normal behavior. I've even tried turning the camera off to reset, pushing the cocking lever back in towards the body and moving the dial to L position, The camera still fires at whatever speed the shutter was cocked at. I've reviewed the manual and it doesn't say anything about it.

Batteries are good and it does this whether there's a lens attached or not.

Anyone have any ideas?

Thanks!

Kris

10-26-2012, 02:31 AM   #2
Giveaway winner!
MysteryOnion's Avatar

Join Date: Dec 2007
Location: beantown
Photos: Albums
Posts: 887
That does sound as if the camera's meter is fine, but the part of the circuit that receives and set the time to fire the shutter is not fine.
The duration of the shutter is sort of held in a type of memory and that is what must cause the magnet in the shutter to activate and push... I think.

QuoteOriginally posted by klphoto Quote
...when the meter reads 1/1000, then point the camera at something dark and the meter indicates 1 sec, the camera will still fire at 1/1000...
The question is, are you sure it is 1/1000th that it is stuck on?

If the magnet will not do the holding of the shutter or is just dead, the speed should be about 1/125th and might mean the magnet failure.
If stuck at a high speed, then the main board is shorted out and not able to change speed correctly.

Unfortunately, it is always hard tell what is really going on without opening the camera up.
10-26-2012, 06:30 AM   #3
New Member




Join Date: Oct 2012
Posts: 4
Original Poster
Yeah, the shutter isn't stuck on any particular shutter speed. It depends what the meter reads when I cock the shutter. If I do the opposite (point at something dark first) it will shoot at a slow speed, even if I point at something really bright just before i hit the button. I'm pretty good at hearing shutter speed differences, so I know all of the speeds work. It just doesn't change according to conditions after I wind.
10-26-2012, 07:19 AM   #4
Site Supporter




Join Date: Jan 2010
Location: Michigan
Photos: Gallery
Posts: 2,073
KL,
When the rewind lever is all the way retracted, the metering and leds should operate only when the button is halfway down, and the leds should go off when you take your finger off the button. When the rewind lever is at 30 degree position the metering and leds should come on when the button is halfway down and stay on until the lever is retracted in. That means, the metering shouldl stay on even if you take your finger off the button.
Is that occurring?

10-26-2012, 07:31 AM   #5
New Member




Join Date: Oct 2012
Posts: 4
Original Poster
Yes, it's behaving exactly as you've described with the lever in each position and the half-press shutter. The meter will change with varying lighting conditions and it's responsive, so it appears to be measuring light properly. It's the shutter speed chosen by the camera that does not change once I wind the lever (even if the meter indicates something different). It's almost as if the act of winding locks in the shutter speed and prevents it from changing, regardless if the meter reading changes again.
10-26-2012, 07:43 AM   #6
Giveaway winner!
MysteryOnion's Avatar

Join Date: Dec 2007
Location: beantown
Photos: Albums
Posts: 887
It is as if you have exposure lock?

I refreshed my memory about memory on the ME by looking it up in the service manual and it does seem that the problem is "memory" related.

It could be that the memory switch is stuck after you press down for metering or it is possible that the memory switch found on the mirror box area is not disengaging?

Either way, the camera needs to by checked

Last edited by MysteryOnion; 10-26-2012 at 07:52 AM.
10-26-2012, 07:59 AM   #7
Site Supporter




Join Date: Jan 2010
Location: Michigan
Photos: Gallery
Posts: 2,073
Yes
You can get the service manual from
PENTAX MANUALS
It refers to time lag sequence between memory and magnet switches and how to check and adjust.
The trouble shooting refers to similar problems but not directly to yours.
Hope you get it working!
10-26-2012, 11:39 AM   #8
New Member




Join Date: Oct 2012
Posts: 4
Original Poster
Great, I will check into the memory switch. Thanks to both of you!

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, cock, meter, pentax me shutter, shutter, shutter speed vs
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax Spotmatic light meter issue kcobain1992 Pentax Film SLR Discussion 18 02-27-2017 06:01 AM
Issue with my Pentax Analog Spot Meter V Bogie Troubleshooting and Beginner Help 2 03-12-2011 06:51 AM
Pentax KX Shutter starting to stuck at slow shutter speed. Spirit722 Pentax Film SLR Discussion 7 03-03-2011 09:49 PM
Pentax Spotmatic F issue with light meter LosHollyBeach Pentax Film SLR Discussion 7 12-30-2010 05:57 PM
K-x Av with auto-ISO: slow shutter speed issue Karellen Pentax DSLR Discussion 6 02-22-2010 03:58 PM



All times are GMT -7. The time now is 09:22 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top