Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-15-2012, 11:20 AM   #1
New Member




Join Date: Dec 2012
Posts: 7
Auto 110 Light Meter Help

Hi All,

I'm a noob to this forum and I joined specifically because I'm starting to shoot on an Auto 110 I acquired at a sidewalk sale for $20.(!!!)

I shot a roll of film - brand new stuff from lomography.com - and it came back blank. I do not have the negatives yet; I know it's blank because the lab informed me. Naturally, I want to find out what's wrong. The obvious issues are null (lens cap was off, film advances, the shutter functions).

One possibility is dead batteries - I neglected to replace them before shooting. I just replaced them, but have noticed that there is no indicating light in the viewfinder. Now, there is no film in the camera, but I didn't think there needed to be film in the camera in order for the light meter to function (Then again I am a n00b to this camera, and I was born in 1985 so SLR cameras are still somewhat new to me!)

There IS supposed to be an indicating light in the viewfinder, yes? And the camera DOES need batteries in order to shoot a roll of film that will actually be exposed, yes? If this is the case, why wouldn't the indicating light be functioning, if the batteries are new? How can I find out what would be malfunctioning?

Please help me learn more about how this camera is supposed to function, and possible issues I could be having.

Thank you!!

12-15-2012, 12:07 PM   #2
Site Supporter
grhazelton's Avatar

Join Date: Jul 2007
Location: Jonesboro, GA
Photos: Albums
Posts: 1,788
Congrats on your purchase! Michael Butkus has a wonderful site with many instruction manuals. Have a look at Pentax Auto 110, Pentax Auto 110 super, and send Mike a few dollars to keep up the good work!
12-15-2012, 02:20 PM   #3
New Member




Join Date: Dec 2012
Posts: 7
Original Poster
THanks for the reply. I think I'm on track with a possible cause - closer inspection reveals that the battery casing is coroded and cracking. Acid from the old batteries leaked out, and possibly some of the underlying electronics have been damaged. I'm going to try to open up the camera to investigate further...
12-15-2012, 06:38 PM   #4
New Member




Join Date: Dec 2012
Posts: 7
Original Poster
Hi again, I just want to report on my progress. I opened up the camera thanks to the Disassembly Guide found here at pentax110.co.uk - just enough to take out the battery casing. It was decrepit and needed cleaning from corrosion and to be glued back together. During this process I had to re-solder 2 wires (and it's a crappy job b/c I'm not very good at it) but i got the light meter functioning again! Now the next test is to shoot a roll of film and see if anything develops.

02-02-2013, 01:38 PM   #5
Junior Member




Join Date: Jun 2010
Location: Pennsylvania
Photos: Albums
Posts: 44
QuoteOriginally posted by opuntia Quote
Hi again, I just want to report on my progress. I opened up the camera thanks to the Disassembly Guide found here at pentax110.co.uk - just enough to take out the battery casing. It was decrepit and needed cleaning from corrosion and to be glued back together. During this process I had to re-solder 2 wires (and it's a crappy job b/c I'm not very good at it) but i got the light meter functioning again! Now the next test is to shoot a roll of film and see if anything develops.
How did your test roll work out?

My Auto 110 is doing the same thing- there's fresh batteries in it but the light meter doesn't illuminate. Before I run a roll through it, it'd be nice to know if the simple repair you did got you going again...
02-05-2013, 10:19 AM   #6
New Member




Join Date: Dec 2012
Posts: 7
Original Poster
Hi contrabass, if the light meter does not work, it will NOT take photos! My repair worked out fine and I've been able to develop several rolls. I would suggest doing what I did, performing a bit of minor surgery.
02-05-2013, 10:20 AM   #7
New Member




Join Date: Dec 2012
Posts: 7
Original Poster
Just to be clear, my repair job WORKED! I'm now able to take photos, which i get processed at a lab I mail my rolls to.
02-05-2013, 10:25 AM   #8
Veteran Member
mrNewt's Avatar

Join Date: Nov 2011
Location: ON, RH
Posts: 2,170
QuoteOriginally posted by opuntia Quote
Just to be clear, my repair job WORKED! I'm now able to take photos, which i get processed at a lab I mail my rolls to.
Where do you send your films?
I have a 110 and a few films in the fridge ... didn't used them because I don't know of any lab that still does those films.

02-05-2013, 10:33 AM - 1 Like   #9
New Member




Join Date: Dec 2012
Posts: 7
Original Poster
I mail them to The Darkroom. First class shipping within the US to them is free, and for approx. $12 per roll you get negatives and scans of your developed photos on a website they upload them to. From there you can order prints which are extra. You can mail up to 5 rolls of film at one time on one of their shipping labels, and shipping your negs back to you costs me about $4, but i live in the East Coast of the US.
02-05-2013, 10:36 AM   #10
Veteran Member
mrNewt's Avatar

Join Date: Nov 2011
Location: ON, RH
Posts: 2,170
Sweet - thanks for the info!
I'll definitely give them a try!
02-06-2013, 07:30 PM   #11
Junior Member




Join Date: Jun 2010
Location: Pennsylvania
Photos: Albums
Posts: 44
QuoteOriginally posted by opuntia Quote
Hi contrabass, if the light meter does not work, it will NOT take photos! My repair worked out fine and I've been able to develop several rolls. I would suggest doing what I did, performing a bit of minor surgery.
Cool!

I suppose I'll try the same thing, too.
04-09-2015, 08:48 AM   #12
New Member




Join Date: Apr 2015
Posts: 2
Hi everybody,
Im planning to buy a Pentax Auto 110 but when i got to see the camera i noticed that the light meter was not functioning.
The battery casing is coroded and i guess thatīs the problem. Could you specify me which cables you had to re-solder?
Iīm reading the disassembly guide but would be gratefull if you could give me further information.
Thank you!
04-09-2015, 11:03 AM   #13
Site Supporter




Join Date: Jan 2010
Location: Michigan
Photos: Gallery
Posts: 2,070
I have the P110 lenses which I use on M43 (same frame size as P110) I don't have a body
I would be interested to see some scans ( film or print) from the P110 camera.

Keep up the good work repairing the old cameras!
04-13-2015, 10:44 AM   #14
New Member




Join Date: Dec 2012
Posts: 7
Original Poster
QuoteOriginally posted by Lucardillo Quote
Hi everybody,
Im planning to buy a Pentax Auto 110 but when i got to see the camera i noticed that the light meter was not functioning.
The battery casing is coroded and i guess thatīs the problem. Could you specify me which cables you had to re-solder?
Iīm reading the disassembly guide but would be gratefull if you could give me further information.
Thank you!
Hi, I responded via PM but wanted to answer publically too - the cables I needed to resolder were 2 connected to the battery. The only reason I had to resolder was because the joints became corroded and filthy, and the current wasn't passing through as a result. Also, one of the cables broke during the cleaning :-p So it's probably best to disconnect the wires, clean the joints, and solder.
05-05-2015, 07:47 AM   #15
New Member




Join Date: Apr 2015
Posts: 2
Thank you! I appreciate your answer.
I should receive the camera this week. Iīll write again with forward information on the process ; )
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
batteries, camera, film, function, issues, light, light meter, meter, roll
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help with Light Meter Debra Heschl Pentax Camera and Field Accessories 3 11-03-2011 11:35 AM
Pentax ME Super Light Meter problems! PLEASE HELP thekidwho Troubleshooting and Beginner Help 8 09-06-2011 03:15 PM
Something nice for our Pentax Auto 110 users: Auto 110 lens database Adam Pentax Film SLR Discussion 3 09-24-2010 06:42 AM
Help with light meter srpickel Troubleshooting and Beginner Help 6 02-18-2010 03:49 PM
Pentax 110 Auto Pricing Help??? Sunnyqueensland General Talk 3 05-09-2008 09:32 PM



All times are GMT -7. The time now is 05:34 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top