Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-16-2013, 12:59 PM   #1
Inactive Account




Join Date: Feb 2013
Posts: 1
Pentax ME rapid-wind lever problem

i just bought this used pentax me camera i put the film and every thing was working fine until i took my 20th picture then the lever stopped working i dont know what happen it feel disconnected like if you move it it wont move back , this is my first camera so i what i know about cameras is the basic

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, lever, move, pentax
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
P30 Wind Lever Doesn't Wind Complete Cycle - Any ideas? pengam Pentax Film SLR Discussion 14 08-31-2015 06:08 AM
ME super wind lever problem Cat among the pigeon Pentax Film SLR Discussion 11 07-14-2015 06:28 PM
Pentax P30 - Wind Lever Problem. nat.mitch Troubleshooting and Beginner Help 3 10-28-2012 06:43 PM
Pentax ME Super - Aperture Lever Problem ioszhka Pentax Film SLR Discussion 9 02-10-2011 03:30 AM
Me-super rapid wind lever not returning properly Heldur Pentax Film SLR Discussion 13 10-10-2008 12:45 AM



All times are GMT -7. The time now is 01:58 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top