Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-03-2013, 03:48 AM   #1
Site Supporter
pixelvandal's Avatar

Join Date: Dec 2012
Location: Gold Coast
Posts: 164
spotmatic - surprise, light meter issue

so I got given a spotmatic sp recently by an old friends father. Its a beautiful old camera, in great condition. And at some stage its definitely had a cla. New light seals, new focus screen. Very tidy looking. But the meter appears to be dead.
tried replacing the battery, no luck. When I move the switch. It pushes the plate forward and stops down lenses as it should. But there doesn't appear to be any movement with the meter. Its sitting halfway between correct exposure. And the +. Tried the battery test trick and nothing. Cleaned the contacts, spun the shutter speed dial to clean out the 'dust' that may have built up and.... Nothing still.

I have the service manual, before I start playing with it, I want to know if anyone has any ideas? I know its probably easier to get a handheld meter, but its become a mission of mine to try fix! Haha

10-03-2013, 09:59 AM   #2
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 26,467
Turn the battery the other way? The positive pole (+) should be facing inward.


Steve
10-03-2013, 11:48 AM   #3
Veteran Member
titrisol's Avatar

Join Date: Dec 2007
Location: In the most populated state... state of denial
Photos: Gallery | Albums
Posts: 1,094
Take the bottom plate out and check whether corrosion has gotten the wires desoldered from the battery compartment
If that is not the case, you maybe up for a lot of dissassembling
10-03-2013, 11:50 AM   #4
Veteran Member
titrisol's Avatar

Join Date: Dec 2007
Location: In the most populated state... state of denial
Photos: Gallery | Albums
Posts: 1,094
How it looks without bottom plate


10-03-2013, 02:19 PM   #5
Site Supporter
pixelvandal's Avatar

Join Date: Dec 2012
Location: Gold Coast
Posts: 164
Original Poster
looks like they are still attached. at least.... the negative one that i can see.

bugger.

and yes the positive pole is facing inward, definitely not the battery. sigh.

so....what would be the next course of action you would suggest?



Last edited by pixelvandal; 10-03-2013 at 02:30 PM.
10-05-2013, 07:08 PM   #6
Veteran Member
titrisol's Avatar

Join Date: Dec 2007
Location: In the most populated state... state of denial
Photos: Gallery | Albums
Posts: 1,094
It's all clean and in good shape.... that goes beyond my ability unfortunately
The only thing I could try is using a multimeter and checking if the circuit is closing when you flip the lightmeter switch.
10-07-2013, 11:43 PM   #7
Site Supporter
K David's Avatar

Join Date: Oct 2012
Location: SF Bay Area
Photos: Gallery
Posts: 1,246
Check your settings and location, too. The meter is an older one and if you test it indoors the light levels may be beyond it's range. Try it outside in full sunlight and see if it works.
10-08-2013, 10:59 PM   #8
Site Supporter
pixelvandal's Avatar

Join Date: Dec 2012
Location: Gold Coast
Posts: 164
Original Poster
well tested it with a multimeter. Between the point of contact for the positive, which it the metal tab, and the body, which I assume is the negative. And when I flick the switch its not closing the circuit. So do I need to attack the switch? Does anyone know anyone in Australia who repairs old cameras?

10-10-2013, 07:34 AM   #9
Veteran Member
titrisol's Avatar

Join Date: Dec 2007
Location: In the most populated state... state of denial
Photos: Gallery | Albums
Posts: 1,094
I checked last night and when the circuit is engaged (switch on) the resistance moved just a little bit... not very much
I agree, you need someone with knowledge to look at it
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax Spotmatic light meter issue kcobain1992 Pentax Film SLR Discussion 18 02-27-2017 06:01 AM
Questions about light meter on Spotmatic. captmorgan23 Pentax Film SLR Discussion 5 06-23-2013 10:34 AM
question re: light meter on spotmatic f mlynn Pentax Film SLR Discussion 4 09-15-2012 08:20 AM
Pentax Spotmatic F issue with light meter LosHollyBeach Pentax Film SLR Discussion 7 12-30-2010 05:57 PM
Need help: Spotmatic F light meter problem Spottie Pentax Film SLR Discussion 11 11-11-2008 07:02 PM



All times are GMT -7. The time now is 03:47 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top