Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-17-2013, 11:29 AM   #1
Pentaxian
paulh's Avatar

Join Date: Sep 2010
Location: DFW Texas
Photos: Gallery | Albums
Posts: 13,898
Newly cla'd H2 won't fire

Hi everyone. I just received my H2 back from Eric a few days ago. I sent it in for a CLA and a sticking curtain repair. It looks great and seemed to be working perfectly when I did some "dry-firing" without film or a lens mounted. Today I put my SMC Tak 55/1.8 on it, set to manual, cocked the film advance, and the shutter button won't depress. I removed the lens, and tried again thru a range of shutter speeds, but no luck. Can anyone offer some advice? The Tak 55 is the only screwmount lens I own at the moment. Is there somehing I may have done wrong? This is my first pre-Spotmatic screwmount body. Thanks in advance!

12-17-2013, 12:01 PM   #2
Giveaway winner!
MysteryOnion's Avatar

Join Date: Dec 2007
Location: beantown
Photos: Albums
Posts: 933
Could you verify if you can see the metal edge of the shutter curtain? If yes, this means the action is not clearing the arm similar to below...



A moves in the slot and hit the lever arm and then sit on the position B.

It could be that your mechanism hangs just prior to this finished state at the green circle.

Last edited by MysteryOnion; 12-18-2013 at 07:54 AM.
12-17-2013, 12:22 PM   #3
Pentaxian
paulh's Avatar

Join Date: Sep 2010
Location: DFW Texas
Photos: Gallery | Albums
Posts: 13,898
Original Poster
@mysteryonion: Thanks for the quick reply. If you mean the metal curtain edge is visible when opening the back of the camera, no it isn't. I'm heading to work now, but will take photos tonite or tomorrow. Thanks again.
12-17-2013, 12:35 PM   #4
Loyal Site Supporter
monochrome's Avatar

Join Date: Mar 2008
Location: Kirkwood (St. Louis) MO
Photos: Gallery | Albums
Posts: 20,455
paulh: Download a manual from Pentax-Manuals.com (the password is Pentax) to ensure you've taken all the correct actions first. Check that you are not on Bulb; try opening and closing the camera back to reset the mechanism; ensure you have advanced the lever a full stroke (but do not force it)

If none of those work return the camera to Eric - he will correct whatever is amiss.


Last edited by monochrome; 12-17-2013 at 12:44 PM.
12-17-2013, 02:42 PM   #5
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,502
QuoteOriginally posted by paulh Quote
Hi everyone. I just received my H2 back from Eric a few days ago.
What does Eric say? He stands behind his work. Better to consult with him before fiddling inside the camera.


Steve
12-17-2013, 10:28 PM   #6
Pentaxian
paulh's Avatar

Join Date: Sep 2010
Location: DFW Texas
Photos: Gallery | Albums
Posts: 13,898
Original Poster
Thanks everyone for your replies. I don't intend on trying my own repairs. I thought that there was a possibility that the newer SMC Tak lens might have some compatibility issues with the older screwmount bodies. I'll email Eric tomorrow & go from there. Thanks again.
12-17-2013, 11:07 PM   #7
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,502
QuoteOriginally posted by paulh Quote
Thanks everyone for your replies. I don't intend on trying my own repairs. I thought that there was a possibility that the newer SMC Tak lens might have some compatibility issues with the older screwmount bodies. I'll email Eric tomorrow & go from there. Thanks again.
The 50/1.4 maybe, but the 55/1.8 is unlikely.


Steve
12-18-2013, 06:26 AM   #8
Loyal Site Supporter
G and T's Avatar

Join Date: Aug 2011
Location: Langwarrin Australia
Photos: Gallery
Posts: 351
QuoteOriginally posted by paulh Quote
I thought that there was a possibility that the newer SMC Tak lens might have some compatibility issues with the older screwmount bodies.
I can confirm that there is no compatibility issues with your SMC Tak 55/1.8 , I have one and it works perfectly on both my H2's.
Glenn

12-18-2013, 07:50 AM   #9
Giveaway winner!
MysteryOnion's Avatar

Join Date: Dec 2007
Location: beantown
Photos: Albums
Posts: 933
Not noticed issues with my S2 and a 55/1.8 either. Was the camera stored at a temperature that is a bit chilly? The older rubberized curtains can be stiff when cold.
12-18-2013, 08:26 AM   #10
Pentaxian
paulh's Avatar

Join Date: Sep 2010
Location: DFW Texas
Photos: Gallery | Albums
Posts: 13,898
Original Poster
Well, I think I discovered the problem. The shutter button was still stuck this morning, so I cranked the film advance lever all the way, then gave it a little extra nudge at the end. That did it! It seems fine now after repeating that several times. I just have to make sure I crank the lever all the way to the stop (like you're supposed to)! Thanks again, everyone.
12-18-2013, 05:00 PM   #11
Pentaxian
ChrisPlatt's Avatar

Join Date: Nov 2007
Location: Queens NYC
Posts: 4,865
Compared to later models many older cameras require a relatively longer stroke for film advance.

Chris
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
advance, film, h2, lens, screwmount, shutter, tak
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Shutter won't fire anselesn Troubleshooting and Beginner Help 5 07-20-2013 04:30 PM
Flash won't fire :( What's up? slr_neophyte Troubleshooting and Beginner Help 2 12-25-2012 05:12 PM
For Sale - Sold: Pentax SL and CLA'd Pentax H2 Crazy Fedya Sold Items 9 01-28-2011 09:23 PM
For Sale - Sold: FS: Newly CLA'd Pentax MX... ChrisM Sold Items 22 04-21-2008 03:16 AM



All times are GMT -7. The time now is 04:34 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top