Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-28-2013, 02:51 AM   #1
Veteran Member
richard balonglong's Avatar

Join Date: Aug 2007
Location: Baguio City, Philippines
Photos: Gallery
Posts: 350
Pentax Super A/Program Won't Fire: HELP

Hello!

I just bought a Pentax Super A/Program from an online seller. The seller is not a photographer, so he doesn't know if the camera is working when I asked him.
Anyway, when I received the camera I immediately put on a new batteries and loaded a film. The camera won't fire after I crank the camera. I tried it several times but nothing happens. And, I can't even adjust the shutter speed. It only stays to 1000. The buttons looks like it's not working.
I need help with this.

Thanks in advance!

Richard B.

12-28-2013, 03:22 AM   #2
Inactive Account




Join Date: Dec 2008
Location: North Carolina
Photos: Albums
Posts: 1,720
It is supposed to stay at 1000 for the first few shots, those are the wasted ones caused by loading the film. Once the exposure counter is on 1 it will allow you to set the shutter speed as usual.

As for not firing it could be dirty contacts under the shutter button.
12-28-2013, 07:39 AM   #3
Veteran Member
richard balonglong's Avatar

Join Date: Aug 2007
Location: Baguio City, Philippines
Photos: Gallery
Posts: 350
Original Poster
QuoteOriginally posted by elliott Quote
As for not firing it could be dirty contacts under the shutter button.
How do I clean it? Is it possible to open and then clean it?
12-28-2013, 08:18 AM - 1 Like   #4
Pentaxian




Join Date: May 2011
Location: Santa Cruz, CA
Photos: Albums
Posts: 2,044
If you are so inclined, you can get the the service manual at -> http://www.robertstech.com/manuals.htm

12-28-2013, 09:07 AM - 1 Like   #5
Pentaxian
paulh's Avatar

Join Date: Sep 2010
Location: DFW Texas
Photos: Gallery | Albums
Posts: 13,864
Not sure if this applies to your Super Program, but make sure you crank the film advance all the way. I thought I had a problem with a stuck H2 - it turned out that I just hadn't pushed the film advance lever all the way to the stop.
12-28-2013, 12:30 PM - 1 Like   #6
Veteran Member




Join Date: Jan 2013
Location: Florida
Posts: 381
Mine was getting stuck and I shipped it off to Eric for a CLA / repairs along with a donor body. Sometimes these old cameras are worth fixing, sometimes not. I now have a great camera, but of course you have to get it taken care of.
12-28-2013, 12:36 PM - 1 Like   #7
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,438
Ummm...it appears that your camera is not working.

Fresh batteries inserted properly in holder?
Shutter properly cocked?

Shutter should fire when pressed. It makes no difference whether the film door is open or shut.

Was the camera described as being in working order? If so, send it back. If not, I hope you did not pay more than the value for parts (~$15 USD). The issue may be simple and easily fixed (mirror stuck up?) or tragic (main board failure). Lesson: If the seller claims ignorance about the item, do no pay them any money.


Steve
12-28-2013, 09:00 PM   #8
Veteran Member
richard balonglong's Avatar

Join Date: Aug 2007
Location: Baguio City, Philippines
Photos: Gallery
Posts: 350
Original Poster
QuoteOriginally posted by stevebrot Quote
Ummm...it appears that your camera is not working.

Fresh batteries inserted properly in holder?
Shutter properly cocked?

Shutter should fire when pressed. It makes no difference whether the film door is open or shut.

Was the camera described as being in working order? If so, send it back. If not, I hope you did not pay more than the value for parts (~$15 USD). The issue may be simple and easily fixed (mirror stuck up?) or tragic (main board failure). Lesson: If the seller claims ignorance about the item, do no pay them any money.


Steve
Yeah, I did all of that. Fresh batteries and properly cocked. The LCD displays just fine. But when pressing the shutter, nothing happens...
The seller told me he found the camera from their house, it's from his parents. In my side, it's a risk taken, a gamble. I bought it for $70 for the camera PLUS with a Pentax A 35-105mm f/3.5! I think I win on risk taking. The lens' front element just needs a minor cleaning...

12-29-2013, 11:53 AM   #9
New Member




Join Date: Nov 2011
Location: Minden Hills, Ontario
Posts: 24
Here are some hints for the ME Super. Had same problem with my Super Program. Try the re-setting trick. 3 Screws and bottom comes off easily.

Favorite Classics > Pentax ME Super Ramblings > Three Common Failure Problems

/Clay
12-30-2013, 01:39 AM   #10
Veteran Member
richard balonglong's Avatar

Join Date: Aug 2007
Location: Baguio City, Philippines
Photos: Gallery
Posts: 350
Original Poster
QuoteOriginally posted by Clay Quote
Here are some hints for the ME Super. Had same problem with my Super Program. Try the re-setting trick. 3 Screws and bottom comes off easily.

Favorite Classics > Pentax ME Super Ramblings > Three Common Failure Problems

/Clay
Thanks man! Did it work on your Super Program?
12-30-2013, 05:56 AM   #11
New Member




Join Date: Nov 2011
Location: Minden Hills, Ontario
Posts: 24
It worked for about half a roll, then jammed up again. Will send to Eric for a pro fix.

/Clay
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, film, fire, help, pentax, program, seller, slr, super a, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale - Sold: Mint Pentax Super Program, Pentax A 50mm 1.7 and Pentax AF 280 T jjdgti Sold Items 2 10-29-2013 07:40 PM
Shutter won't fire anselesn Troubleshooting and Beginner Help 5 07-20-2013 04:30 PM
Super A / Super Program won't fire. Hamster Pentax Film SLR Discussion 2 07-28-2012 09:52 AM
Pentax Program Plus - Shutter won't work amberlynn531 Troubleshooting and Beginner Help 4 02-15-2012 07:56 PM
Help!! 67 Shutter won't fire. Swift1 Pentax Medium Format 5 10-05-2009 01:05 PM



All times are GMT -7. The time now is 11:54 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top