Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-04-2014, 08:26 AM   #1
Senior Member
johnha's Avatar

Join Date: Apr 2012
Location: Lancashire, UK
Posts: 250
K2 shutter on shoots at one speed (manual or auto)

Hi All,

All this talk about K's v M's has prompted me to revisit my K2. Unfortunately it only shoots at one speed irrespective of being set to auto or manual or whether there are batteries in the camera. I don't know which speed (feels like 1/60th or faster), the meter appears to reading roughly correctly in both modes. I will try fresh batteries but suspect it needs a repair (if this is still possible?) unless there's something simple anybody can suggest?

John.

01-04-2014, 08:55 AM   #2
Pentaxian




Join Date: May 2011
Location: Santa Cruz, CA
Photos: Albums
Posts: 1,929
When battery is dead, it only shoots at 1/125 which is the manual mechanical speed. If the meter reacts correctly then the batter may be fine but something else electronically is not working correctly. Eric's site lists the K2 but of course he is in the US -> Home
01-04-2014, 10:51 AM   #3
Veteran Member
Cuthbert's Avatar

Join Date: Nov 2013
Photos: Gallery
Posts: 1,573
Try two new batteries, then battery checks and select the 1 sec speed to make sure it works.
01-04-2014, 10:57 AM   #4
Lens Buying Addict
monochrome's Avatar

Join Date: Mar 2008
Location: Kirkwood (St. Louis) MO
Photos: Gallery | Albums
Posts: 19,493
Does the battery check lamp glow red when you press the black test button? If it remains dark the battery is dead - if it glows red the battery is good. There is a UK version of Eric at (I think) HarrowTech. There are posts about him here in the Film Forum. A quick post asking for his contact info should get a fast response.

01-04-2014, 12:57 PM   #5
Senior Member
johnha's Avatar

Join Date: Apr 2012
Location: Lancashire, UK
Posts: 250
Original Poster
Thanks all. The battery check lamp is intermittent (flickering red, dull red & bright red) but I think that's the check switch. I'll try some new batteries first. The needle sits at the top without a battery in the camera, is that normal?

Thanks Monochrome - I've got HarrowTech's details.

John.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
auto, batteries, k2
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Shutter speed mode using manual lenses WangJianWei Pentax K-01 2 06-11-2013 11:37 PM
Manual shutter speed? Plainfaced Pentax K-01 8 03-18-2013 11:36 AM
Video mode and manual shutter speed/ISO ? alamm001 Pentax K-01 10 12-12-2012 04:49 AM
cannot adjust shutter speed in manual on K-x.. ARSLONGA VITABREV Troubleshooting and Beginner Help 14 03-25-2010 10:32 PM
HELP- when in auto mode why is my shutter speed at 1/80, BLURRED PICS!! Jori Troubleshooting and Beginner Help 16 11-30-2009 09:19 AM



All times are GMT -7. The time now is 01:38 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top