Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-30-2014, 08:33 PM   #1
Forum Member
JuanEstrada's Avatar

Join Date: Jan 2014
Location: Bogotá, Colombia!
Posts: 87
K2 diaphragm ring problem

Hi guys.

I got a black K2 from the bay and when you open the lens diaphragm, the lecture on the viewfinder changes, but that does not happen when you close it, or it happens very very very slowly. So, I checked the camera without the lens and found out that the lever that matches the lens it is not working properly, as shown in the video


that didn't happen before with my silver k2 and now it does... is there a way to fix this?

Thanks!

05-02-2014, 05:56 PM   #2
Forum Member
JuanEstrada's Avatar

Join Date: Jan 2014
Location: Bogotá, Colombia!
Posts: 87
Original Poster
Someone please help. That seems like a quick fix but I don't want to break it.
05-02-2014, 07:11 PM - 1 Like   #3
Site Supporter
gofour3's Avatar

Join Date: Oct 2008
Location: Vancouver, Canada
Posts: 5,289
QuoteOriginally posted by JuanEstrada Quote
Someone please help. That seems like a quick fix but I don't want to break it.
I would email Eric and see what he thinks, he'll know for sure.

Pentax Camera Services

Phil.
05-03-2014, 10:07 PM   #4
Forum Member
JuanEstrada's Avatar

Join Date: Jan 2014
Location: Bogotá, Colombia!
Posts: 87
Original Poster
Thanks, already did, let's wait for an answer... however, if someone knows how to do it, please let me know!

05-05-2014, 12:48 PM   #5
Giveaway winner!
MysteryOnion's Avatar

Join Date: Dec 2007
Location: beantown
Photos: Albums
Posts: 921
It might be possible to peek with a bright light and verify if the spring is still hooked to the ring or the screw that secures it is off or gone or the spring is broken?

If the ring was snapped back too hard, the loop end might have detached. It is possible to remove the mount ring and reattach.
05-05-2014, 06:07 PM   #6
Forum Member
JuanEstrada's Avatar

Join Date: Jan 2014
Location: Bogotá, Colombia!
Posts: 87
Original Poster
Thanks a lot for the answer. I got an answer from Eric and he told me to put a little alcohol in the lever and if it works, then add oil. I worked like a charm!
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
diaphragm, k2, k2 diaphragm, lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Backwards diaphragm blades jddwoods Pentax SLR Lens Discussion 4 12-11-2013 05:54 PM
Diaphragm problem Poliyoyo Pentax SLR Lens Discussion 4 05-09-2012 09:44 PM
DA 40 Diaphragm Blade Problem? Colorado CJ Pentax SLR Lens Discussion 31 12-26-2010 01:40 AM
? K2 K2-DMD focus screens Moe49 Pentax Film SLR Discussion 4 10-18-2010 06:25 AM
K200D Problem with aperture ring g-kun Pentax DSLR Discussion 7 08-09-2008 08:13 AM



All times are GMT -7. The time now is 08:56 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top