Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-22-2014, 05:28 PM   #1
Site Supporter




Join Date: Jul 2012
Photos: Gallery | Albums
Posts: 4,241
Please, celebrate me home.

Greetings,

Okay, I have an old school Asahi Spotmatic F. I love this old gal and would hate to part with it. My problem is, I believe my hotshoe has turned into a coldshoe. None of my Pentax flash units fire on this unit. Yes, I have cleaned both the hotshoe on the camera and the connectors on the flash base. Yes, I have used the shutter speed 60X sync and no dice. My Pentax flash units work perfectly on all my other Pentax cameras. Now, the camera has two female receptors just next to the lens for wire connections, however, my flash units do not.

Any assistance will be greatly appreciated.

Tony

09-22-2014, 09:39 PM   #2
Senior Member
pezmaker's Avatar

Join Date: Jul 2011
Location: Madison, WI
Photos: Gallery | Albums
Posts: 276
You should contact the great, amazing Eric. He's done wonders for me, including fixing and shipping an ME Super mas rapido for a Christmas delivery on trust. So what I'm saying is he does great work and he truly cares about the work he does and the people he's doing it for.

His site: Contact Us
09-26-2014, 09:45 PM   #3
Pentaxian
arnold's Avatar

Join Date: Aug 2012
Location: Queensland
Photos: Gallery | Albums
Posts: 3,295
Check tightening the screws holding the flash mount. They are below a metal cover. This worked for me on one of my Fs.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, flash, hotshoe, pentax, units
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nature Oh give me a home .... daacon Post Your Photos! 21 08-08-2013 05:35 PM
Please can we get a link on home page for the Q Classico Pentax Q 3 12-27-2012 06:13 PM
Please. Please. Please resell me on Pentax Buschmaster Pentax DSLR Discussion 30 10-10-2012 08:38 PM
Macro Home - Please Feedback Me tkj365 Photo Critique 8 07-10-2012 01:26 PM
Come help me celebrate! (LBA Post) photo_mom Post Your Photos! 11 01-24-2009 02:54 PM



All times are GMT -7. The time now is 12:54 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top