Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-31-2015, 01:36 AM   #1
Pentaxian
Jonathan Mac's Avatar

Join Date: Apr 2009
Location: Madrid, Spain
Posts: 3,913
SFXn autofocus not working

Hi,

I recently bought an SFXn film camera and it looks in good condition, everything seems to work except the autofocus. The motor doesn't move (no sound, nothing) and there isn't even any focus confirmation beep or icon in the viewfinder or on the screen, even manually focusing. The whole thing seems to be inactive.

I've checked it's on (switch at front left, as normal) and everything else I can think of. Has anyone seen this problem or can anyone suggest where the problem might be and how it might be fixed?

If not, I think the camera should be perfectly useable as a manual focus one. The 1/4000th of a second shutter speed will be handy regardless of AF.

Thanks

08-01-2015, 06:43 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,959
Is the clutch on the lens (if any) set to AF, and are the batteries fresh?

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

08-02-2015, 12:07 AM   #3
Pentaxian
Jonathan Mac's Avatar

Join Date: Apr 2009
Location: Madrid, Spain
Posts: 3,913
Original Poster
There's no lens clutch (have tried a couple of lenses) and the batteries are fine.
08-02-2015, 08:51 AM   #4
Loyal Site Supporter
AquaDome's Avatar

Join Date: Jan 2014
Location: New Carlisle, IN
Photos: Gallery | Albums
Posts: 1,399
The AF/MF switch could be corroded from non-use. Exercise it a few dozen times and see if that wakes it up. Also, clean the contacts between the camera and lens.

Do you feel any resistance when manually focusing an AF lens with the camera set to AF? You should feel and hear the gears and motor turning when you turn the focusing ring.

08-03-2015, 01:24 AM   #5
Pentaxian
Jonathan Mac's Avatar

Join Date: Apr 2009
Location: Madrid, Spain
Posts: 3,913
Original Poster
The AF screw does go in and out with the switch and the gears & motor are forced if I turn the focusing ring, so the mechanism is being engaged.

It's as if the whole AF system is just de-activated.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
autofocus, camera, focus, sfxn, sfxn autofocus
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax-F 50mm autofocus not working rafoarc Troubleshooting and Beginner Help 5 05-11-2015 04:03 PM
K-X autofocus not working cyprus Troubleshooting and Beginner Help 17 02-28-2015 12:36 PM
Autofocus on K20 with kitlens is not working killingworthmark Troubleshooting and Beginner Help 8 10-22-2014 01:48 PM
Autofocus not working lskeens Pentax K-r 2 11-02-2013 08:05 AM
Grrr...autofocus on k-x not working rachcobb Troubleshooting and Beginner Help 9 01-10-2012 09:29 AM



All times are GMT -7. The time now is 06:31 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top