Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-28-2015, 11:05 AM   #1
New Member




Join Date: Mar 2015
Posts: 7
Spotmatic shutter or mirror problem

Hi all,

I've been having this intermittent problem with my original Spotmatic. I've had this happen at seemingly random intervals with various lenses. The outside edge of the photo appears correctly exposed, but there's a rectangular "patch" right in the middle of the frame that's blown out. I'm not having any other issues with the mirror jamming, but the lightmeter switch does occasionally stay up after releasing the shutter... and that doesn't seem to coincide with these weird anomalies.

It's a 50 year old camera, so it's probably time for a CLA, but I figured I'd post this here to see if anyone has seen this particular result before.

Here's an example: not the best shot, but I was actively trying to get the camera to do it again.

Attached Images
 
10-28-2015, 12:11 PM - 1 Like   #2
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 26,189
It is hard to say, but I suspect the issue may be a failed or missing felt light seal at the hinge end of the film compartment. The hard edge at bottom is the clue. Examination of the negative strip should show a light leak extending beyond the frame border at the top of the image. It is also possible this is a failure of the felt light trap on the film canister.


Steve
10-28-2015, 12:42 PM   #3
New Member




Join Date: Mar 2015
Posts: 7
Original Poster
Aha... there is indeed a bit of that leaked rectangle extending just beyond the frame border. Upon closer inspection, the seal actually does look pretty flat... the seals were replaced on this camera before I got it, but with felt or wool, not with foam. I'll replace that one and see how things go.

Thanks!
10-28-2015, 10:55 PM   #4
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 26,189
QuoteOriginally posted by darbo Quote
but with felt or wool, not with foam.
The hinge seal is supposed to be thin felt.


Steve

10-29-2015, 10:01 AM   #5
New Member




Join Date: Mar 2015
Posts: 7
Original Poster
QuoteOriginally posted by stevebrot Quote
The hinge seal is supposed to be thin felt.


Steve
Yes, I can see that now that I've gone in to replace it... it wasn't until I went to remove the old seal that I saw how badly it had deteriorated.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, mirror, pentax help, photography, shutter or mirror, spotmatic, spotmatic shutter, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax 6x7 MLU: Battery/Shutter/Mirror Problem. HELP! richard balonglong Pentax Medium Format 7 08-16-2015 12:39 PM
Pentax Spotmatic Mirror Problem hinkypunk465 Pentax Film SLR Discussion 2 11-07-2013 12:55 PM
645D mirror or shutter problem jani80 Pentax Medium Format 4 09-29-2012 11:39 PM
mirror problem with pentax spotmatic emanuelelectricity Pentax Film SLR Discussion 3 05-21-2010 01:32 PM
K-7 shutter/mirror problem zerodaze Pentax DSLR Discussion 15 08-18-2009 05:54 PM



All times are GMT -7. The time now is 10:44 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top