Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-23-2016, 09:32 AM   #1
New Member




Join Date: Jan 2016
Posts: 8
Pentax ME shutter problem

Hi, I got film camera bug and picked up another film camera from my local craigslist. This time it is Pentax ME comes with 50mm 2.0 lens. The shutter was stuck but seller told me that it need new batteries.

I put new batteries in but still same issue. I open up the bottom plate and discovered that camera fires fine when it is upside down position even without batteries. But as soon as I bring the camera back in regular position shutter won't fire.

I am not sure why camera is working fine in upside but got stuck in regular position.....any help?

Thanks, Pendu

01-23-2016, 11:05 AM   #2
Site Supporter
Alex645's Avatar

Join Date: May 2015
Location: Kaneohe, HI
Photos: Albums
Posts: 1,141
I once had the same problem with my Nikon F3HP and it had to be sent in repairs. In that case, I never found out the exact cause but instead had a repair done to fix it; there was something wrong with the shutter release mechanism.

The only other thing I can think of is that perhaps there is a slight gap between the battery and the contact when the camera is upright. Perhaps ever so slightly lift up the lead that would touch the button cell and see if that helps.

Last edited by Alex645; 02-07-2016 at 02:11 PM.
01-23-2016, 12:21 PM   #3
New Member




Join Date: Jan 2016
Posts: 8
Original Poster
Hi Alex,

Thanks for your response. When I took the bottom plate off and took the batteries out, Camera won't fire in upright position but fire totally fine when it is upside down. So batteries are clearly not an issue here. But thanks for the tip.

Thanks, Pendu
01-23-2016, 01:37 PM   #4
UMC
Forum Member
UMC's Avatar

Join Date: Dec 2012
Location: Vienna
Photos: Gallery
Posts: 82
Have a look at this thread https://www.pentaxforums.com/forums/58-troubleshooting-beginner-help/312266-me-super.html . In one of the postings somebody posted a link to a file called "ME Super ramblings" - this is something, that could enligthen your matter.

02-07-2016, 02:05 PM - 2 Likes   #5
New Member
Scanogram's Avatar

Join Date: Mar 2015
Location: Clearwater, FL
Posts: 13
Spring is off

Sorry I'm late to this discussion. Most likely the spring on the release slide has come off (parts A500 and A510). I repaired this exact problem several years ago. It's not an easy fix since the mirror box needs to be removed to gain access.
Attached Images
 
02-07-2016, 08:45 PM   #6
New Member




Join Date: Jan 2016
Posts: 8
Original Poster
Hi Scanogram,

Thanks for the info and diagram listing various parts. As you mentioned that it is a difficult repair, I guess I will sell the camera as is and let someone play with it.

Thanks again.

Pendu
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
batteries, camera, film, pentax, pentax me shutter, position, shutter
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax ME super shutter problem? Jurredb Troubleshooting and Beginner Help 4 10-09-2014 01:27 PM
Me Super shutter problem? betamax Pentax Film SLR Discussion 6 06-17-2011 08:03 AM
ME Super shutter problem gtxtom Pentax Film SLR Discussion 9 05-20-2011 04:43 PM
Super ME Shutter problem johnfin Pentax Film SLR Discussion 5 04-30-2009 08:15 AM
ME Super Shutter speed problem clawhammer Pentax Film SLR Discussion 5 11-10-2008 12:44 PM



All times are GMT -7. The time now is 06:21 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top