Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-04-2016, 01:03 PM   #1
New Member




Join Date: Jul 2015
Posts: 4
ME Super stuck in manual

I have a weird problem with my ME super. When i put it to AUTO, the M-LED in the viewfinders lights up and it wont automatically select a shutter speed, in fact, I works as if it were in manual mode. Where did my auto mode go? Bulb, lock and 1/125 seems to turns off the LEDs, as they should.
Any ideas what the problem might be? The camera otherwise seems to work fine.

02-04-2016, 03:25 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,949
Have you tried putting in fresh batteries?

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

02-04-2016, 06:52 PM   #3
Site Supporter
K David's Avatar

Join Date: Oct 2012
Location: SF Bay Area
Photos: Gallery
Posts: 1,201
If you have fresh batteries, I would suggest that it sounds like a problem with your mode selector switch. I would contact Eric at Home to see about a repair.
02-05-2016, 01:54 AM   #4
New Member




Join Date: Jul 2015
Posts: 4
Original Poster
Ive put in new batteries but to no avail, the problem continues to exist. Ill shoot up the film and dig up the spotmatic, which somehow seems live eternally.
Unless someone else has an idea as to where to, ill ask a repair guy,. Thanks!

02-05-2016, 04:49 AM   #5
Senior Member
Griz57's Avatar

Join Date: Jan 2012
Location: Landisburg, PA
Photos: Albums
Posts: 239
QuoteOriginally posted by Sander.es Quote
Ive put in new batteries but to no avail, the problem continues to exist. Ill shoot up the film and dig up the spotmatic, which somehow seems live eternally.
Unless someone else has an idea as to where to, ill ask a repair guy,. Thanks!
Try cleaning your battery contacts with a pencil eraser.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
auto, mode
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax ME Super's shutter is stuck sombrerobanana Troubleshooting and Beginner Help 8 09-26-2015 07:04 PM
ME Super Help. Back stuck. montman Pentax Film SLR Discussion 18 06-20-2013 02:57 AM
Me Super - Mirror Stuck SCADjacket Pentax Film SLR Discussion 3 09-12-2012 08:56 AM
ME super stuck in B mode vodnik Troubleshooting and Beginner Help 3 08-30-2012 01:43 PM
ME Super - shutter curtain stuck paolojackson Pentax Film SLR Discussion 4 09-20-2009 01:01 PM



All times are GMT -7. The time now is 09:31 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top