Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-07-2018, 11:18 AM   #16
Pentaxian
Eyewanders's Avatar

Join Date: Jan 2008
Location: Olympia, WA
Photos: Gallery | Albums
Posts: 3,100
QuoteOriginally posted by sandy_ada Quote
Not sure if it’s that; Eric repaired/CLA’d it in January. The problem the first time was the silver lever failing to catch the black one, as you said.
Resurrecting this simply to ask if you had any luck remedying this yourself, or if you were able to have Eric address the problem.... ???
Always nice to have a postmortem of sorts on these sorts of threads.

01-02-2019, 03:22 AM   #17
New Member




Join Date: Nov 2018
Posts: 2
QuoteOriginally posted by ctrout Quote

Hi there and Happy new year.
I followed all your steps but it is still jammed. I loaded it with my fingernail but can the shutter button doesn't want to work. Is there anything else I could try?
'Thanks so much for help family'
Attached Images
View Picture EXIF
SM-G9600  Photo 
01-02-2019, 08:47 AM   #18
Veteran Member




Join Date: Aug 2016
Posts: 408
Beyond what is shown in the video that I posted, I don't know how to fix the issue that you are having. It sounds like the problem may be somewhere else inside the camera, like under the top cover, or under the front cover. I am not so brave as to attempt disassembly to that level. Sorry.
05-27-2019, 09:40 PM   #19
New Member




Join Date: Oct 2017
Location: Vancouver, BC
Posts: 11
Original Poster
QuoteOriginally posted by chickentender Quote
Resurrecting this simply to ask if you had any luck remedying this yourself, or if you were able to have Eric address the problem.... ???
Always nice to have a postmortem of sorts on these sorts of threads.
I didn't see this, sorry this a very late followup. I did get it fixed by Eric, who seems to have replaced much of the body. Unfortunately it jammed again in December, and I haven't touched it since. The shutter curtain is looking a little off this time too. I pulled it out of my bag after a plane ride to load it and immediately noticed the curtains, and found that the lever wouldn't move when I tried. Today I dug up a black SV that I have, in hopes of using that instead. I'm not sure if I'll send the other one in for anything, or just give up on it.

08-25-2019, 09:26 AM   #20
New Member




Join Date: Aug 2019
Posts: 1
I’ve the same problem with my SV. But it is odd: I can advance the film lever, but it doesn’t rotate any wheels. Any advices?
12-14-2020, 06:36 PM   #21
New Member




Join Date: Dec 2020
Location: Tlaxcala
Posts: 6
QuoteOriginally posted by ctrout Quote
You freaking legend, you just saved my camera!
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
advance, lever, sv, sv jammed advance
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax mx jammed advanced lever naomimorello Pentax Film SLR Discussion 5 03-04-2018 02:11 PM
MX with jammed shutter Release & advance lever Frosty66 Pentax Film SLR Discussion 5 05-24-2017 01:56 AM
Pentax P5 film film advance jammed Nelson_Rios Pentax Film SLR Discussion 5 02-09-2016 09:14 PM
Film advance jammed on KM Kmman Pentax Film SLR Discussion 22 09-25-2009 06:12 PM



All times are GMT -7. The time now is 03:01 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top