Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-08-2008, 05:10 PM   #1
Senior Member




Join Date: Jul 2008
Location: South Carolina, USA
Posts: 276
Just got my KX!... but it has meter issues

I just got my KX in the mail!!!

It even came with an M 50 1.7 in excellent condition attached to it!

I'm one very happy camper.

Unfortunately it's a bit worse for wear. The shutter is just fine, and the self timer, DOF preview, and MLU all work. But the light meter doesn't. I know about the stand off in the advance lever and all that, and I put fresh batteries in it. The battery check lever doesn't work either.

Do any of you guys know what's wrong with it?

(Oh, and the KX will be making a trip to Eric shortly, you can be sure of that! )

10-08-2008, 08:38 PM   #2
Loyal Site Supporter
Canada_Rockies's Avatar

Join Date: Nov 2007
Location: Sparwood, BC, Canada
Photos: Gallery | Albums
Posts: 9,455
QuoteOriginally posted by Stevopedia Quote
I just got my KX in the mail!!!

It even came with an M 50 1.7 in excellent condition attached to it!

I'm one very happy camper.

Unfortunately it's a bit worse for wear. The shutter is just fine, and the self timer, DOF preview, and MLU all work. But the light meter doesn't. I know about the stand off in the advance lever and all that, and I put fresh batteries in it. The battery check lever doesn't work either.

Do any of you guys know what's wrong with it?

(Oh, and the KX will be making a trip to Eric shortly, you can be sure of that! )
I think you just answered your own question - Eric will fix it, I understand. However, get a pencil eraser and clean the battery terminal in the camera and the inside of the cap that needs to make good contact with the battery. I did this every now and then with my KX when the needle wouldn't go. At least with that camera, even without a battery, you lose no functons at all. I really regret letting mine go, but now am more likely to pick up a back up k something d than another film camera to go with the two I have already.
10-09-2008, 06:55 AM   #3
Senior Member




Join Date: Jul 2008
Location: South Carolina, USA
Posts: 276
Original Poster
I tried the pencil eraser trick, and it worked!

It turned out that there was so much corrosion/such a patina on the metal that it took me half an eraser and 20 minutes until the inside of the battery cover was shiny again. Now the meter is just fine!

A thousand thanks!

(The KX is still going to Eric, though. It needs it.)
10-09-2008, 01:51 PM   #4
Veteran Member




Join Date: Aug 2007
Location: Ottawa
Posts: 365
I had the exact same problem with my KX. Only that I had corrosion on the battery cap threads. A gentle scrubbing with a small wire brush fixed it up very nicely.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
kx, lever, meter
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Spotmatic SP meter Stevopedia Pentax Film SLR Discussion 4 11-09-2009 02:55 PM
K-7 lignt meter mba1971 Pentax DSLR Discussion 2 11-01-2009 06:38 AM
How do YOU meter? anomaly Photographic Technique 70 06-12-2009 10:04 PM
Pentax 67 Light Meter issues BernsPen Pentax Camera and Field Accessories 0 02-11-2009 01:47 PM
KX meter issues Hikari Pentax Film SLR Discussion 4 10-11-2007 05:18 PM



All times are GMT -7. The time now is 10:30 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top