Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-16-2020, 06:08 PM   #1
New Member




Join Date: Sep 2020
Posts: 1
Pentax 67 Wind Lever + Main Gear Issue

Hi friends!

New to the forums here. I was given this camera as a free gift if I could fix it. After doing some research, it appears that others have experienced this problem before. I'm assuming that the wind lever and or main gear are compromised.

Can anyone shed some light on what they think the problem is and if/how I can fix it.

Below is a link to a video that i recorded showcasing the issue.


Thanks!

Adam

09-17-2020, 12:35 AM - 1 Like   #2
pjv
Otis Memorial Pentaxian
Moderator
Loyal Site Supporter
pjv's Avatar

Join Date: Mar 2015
Location: Melbourne, Australia
Photos: Gallery
Posts: 7,289
Thread moved to Pentax Film SLR Discussion forum because members that may be able to help with this issue read this forum.
09-17-2020, 05:05 PM   #3
Senior Member




Join Date: Oct 2015
Posts: 142
I'm not sure if it's the same issue I had (seems a little different) but mine was resolved by cleaning and lubricating the opposite side spool holder under the shutter speed wheel -- that side was binding causing excessive force to be required to advance the film so it stopped advancing while the advance level would slip and still be able to cock the shutter. Lead to some weird accidental half-frame-overlap and 6-multiple-exposures-on-one-frame when it first happened and I didn't realize what was going on.
10-14-2020, 09:05 AM   #4
Site Supporter
Site Supporter
pentaxpete's Avatar

Join Date: Sep 2013
Location: Brentwood, Essex
Photos: Gallery | Albums
Posts: 313
Great to know ! My Wind Lever on my 6x7 Mk 1 has just started to get 'Stiff' so i will check and Lubricate carefully .

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, gear, issue, lever, lever main gear, pentax, pentax 67 wind, pentax help, photography, troubleshooting, wind, wind lever, wind lever issue
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax 67 Wind lever and shutter shutter button L Stymiest Pentax Medium Format 4 01-23-2020 01:27 AM
Pentax MX light meter + wind lever film-love Pentax Film SLR Discussion 5 08-07-2019 11:06 AM
Pentax MX Rapid-Wind Lever Sticking Partway Through Rolls blingblingdr Troubleshooting and Beginner Help 3 07-14-2019 01:39 AM
Problem with wind lever and loading film Pentax K1000 Katalin Troubleshooting and Beginner Help 5 01-11-2019 09:43 AM
P30 Wind Lever Doesn't Wind Complete Cycle - Any ideas? pengam Pentax Film SLR Discussion 14 08-31-2015 06:08 AM



All times are GMT -7. The time now is 02:35 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top