Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-16-2009, 05:58 PM   #1
Junior Member




Join Date: Apr 2009
Location: NY
Posts: 43
help with zx-50

I was playing with zx-50, no film was installed. Suddenly, the shutter seems stuck after I pressed the shutter release button. The viewfinder was all black, i didn't hear shutter release sound but some noise, which sounded like motor sound and lasted for more than 1 second.

Now the camera won't function at all. Whenever I touch any button or change setting, or even just install batteries, that noise will come up.

Also, the lens aperture is not always wide open when I turn the aperture ring.

I guess something got stuck? Any heads-up? Thanks.

05-16-2009, 07:24 PM   #2
Forum Member
CGJung's Avatar

Join Date: Nov 2006
Location: St. Louis
Posts: 92
Idler,

I'm afraid your camera suffers the famous failed mirror motor disease.

Read this post:

https://www.pentaxforums.com/forums/pentax-film-slr-discussion/53977-pentax-z...n-problem.html

ZX-50 has the same motor with that of ZX-5.
05-17-2009, 01:15 PM   #3
Pentaxian
titrisol's Avatar

Join Date: Dec 2007
Location: In the most populated state... state of denial
Photos: Gallery | Albums
Posts: 1,094
Is KAPUT!

read the above post and see if it is worth the try or not.... mine went to camera-heaven (a.k.a. dumpster) after salvaging several parts from it.
05-17-2009, 01:46 PM   #4
Junior Member




Join Date: Apr 2009
Location: NY
Posts: 43
Original Poster
Thanks CGJung!

titrisol, you know what? What happened to your camera was exactly what happened to mine. I got a new battery pack, installed it; After 3 shots ( the last one was with flash on), camera died.

For 20 bucks, I can probably get a used camera instead of just a motor. If I eventually decide to buy a motor to fix it, it would be just for fun.

05-20-2009, 02:42 PM   #5
New Member




Join Date: Feb 2009
Location: France
Posts: 17
Here you have the procedure (including pictures) I wrote to repair it.

https://www.pentaxforums.com/forums/604647-post12.html
Enjoy !
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
aperture, button, noise, release, shutter, sound, zx-50
Thread Tools Search this Thread
Search this Thread:

Advanced Search



All times are GMT -7. The time now is 12:40 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top