Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-29-2009, 01:58 AM   #1
Forum Member




Join Date: Aug 2008
Location: Moline, IL
Posts: 79
Well damn. ME Super fail :(

Seems my ME Super jammed today.

I hit the shutter, which made a strange noise - not like what I'm used to hearing. It was as if the shutter had fired, except the mirror never returned and the film advance is locked. Thankfully it did this as I was advancing the film immediately after putting it in, so I just took it back out, down one frame. Looks to me like the shutter didnt' actually fire, it appears cocked.

Any ideas and/or recommendations of good shops in Nashville, TN or Huntsville, AL?

05-29-2009, 02:58 AM   #2
Veteran Member
geauxpez's Avatar

Join Date: Jul 2008
Location: Atlanta
Photos: Gallery
Posts: 1,197
Poke around a bit here for "jammed ME Super". Similar thing happened to me recently and I was able to get it unjammed by removing the bottom plate and using a screwdriver to move a lever as I pressed the rewind button (or a similar procedure). Might save you some $.

If you want a thorough, reasonably-priced CLA, contact Eric in TN. I believe that he is going on vacation some time this month, so don't panic if he doesn't respond right away. I should be getting two cameras back from him any day now.

Last edited by geauxpez; 05-29-2009 at 03:06 AM.
05-29-2009, 08:08 AM   #3
Veteran Member
Fritz's Avatar

Join Date: Jun 2007
Location: Tillamook, OR
Posts: 1,168
You could try "resetting" the camera. The procedure is described in this link towards the bottom of part 1.
05-29-2009, 11:04 AM   #4
Forum Member
mikebob's Avatar

Join Date: Mar 2007
Location: Denver, CO
Photos: Gallery
Posts: 70
Worked for me!

QuoteOriginally posted by Fritz Quote
You could try "resetting" the camera. The procedure is described in this link towards the bottom of part 1.
I just want to second the above post as my father-in-law's ME Super did this same thing and the link above fixed it. I ended up poking the shutter curtain like instructed and it became unstuck.

Mike

05-29-2009, 05:03 PM   #5
Forum Member




Join Date: Aug 2008
Location: Moline, IL
Posts: 79
Original Poster
Thanks for the insight guys. I'll have to locate my mini screwdrivers and give this a go.
06-01-2009, 05:27 PM   #6
Forum Member




Join Date: Jul 2008
Location: Canada
Photos: Gallery
Posts: 73
I think ill try poking around in mine as well, since its been broken for a while now. Ive given up on it working, and I dont really need it, but it would be nice to sell it working instead of broken.
06-01-2009, 09:35 PM   #7
Forum Member




Join Date: Aug 2008
Location: Moline, IL
Posts: 79
Original Poster
Tried the "reset" method described on that page to no avail. Seems my problem requires removal of the mirror box - which requires desoldering/resoldering wires, a set of skills which I sadly don't possess. I could do it, but I'd be too afraid of hopelessly ruining the camera.

Guess I'll have to shelve it until I can afford to have it repaired.
06-01-2009, 10:15 PM   #8
Forum Member




Join Date: Aug 2008
Location: Moline, IL
Posts: 79
Original Poster
UPDATE!

So I'm just sitting here, browsing ebay for a potential replacement...since it might be cheaper to get another than have this one repaired right?

*click*

I look at the ME Super, and it's fine. As if the jam never happened.

I'm...scared. Glad, but...scared. It's like...Christine...or something. She knew.



Hahaha. Not going to run any film through it until I get it cleaned and lubricated, lest this happen again, mid-roll.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
film, shutter
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Macro FAIL!! Not Epic, but FAIL... icywarm Photo Critique 3 04-28-2010 05:51 AM
Too big to fail? graphicgr8s General Talk 106 04-17-2010 05:49 PM
Which lenses are known to SDM fail? axl Pentax SLR Lens Discussion 23 01-31-2010 02:06 PM
fail title! lmn811118 Troubleshooting and Beginner Help 19 01-12-2010 08:33 PM
Damn, my ME Super is also playing up :( eSFotos Pentax Film SLR Discussion 6 06-08-2009 05:20 AM



All times are GMT -7. The time now is 06:10 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top