Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-30-2009, 12:00 PM   #1
Forum Member




Join Date: Aug 2008
Location: Dallas
Posts: 98
MZ-5 loads film, but then blinks "E"

What mechanism tells the camera that film is loaded incorrectly?

I bought a used MZ-5 that seems in fine condition. It had film in it which I shot up for testing and threw away. When I went to reload film, this happened.

It seems like the camera works fine, but thinks that for some reason the film is loaded wrong, so it blinks "E". The manual unhelpfully suggests that when this happens, the film is loaded incorrectly, and to re-load the film, but I've tried several dozen times now. When I open the camera back I can see the film appears to be loaded perfectly fine...I have to pull it off the take-up spool against the resistance of the motor. The camera works fine with no film as far as I can tell, too. I'd hate to chuck it in the trash when it seems to be working fine absent this one hitch.

07-30-2009, 12:30 PM   #2
Veteran Member




Join Date: Feb 2008
Location: Toronto
Posts: 3,915
if i had to guess, it'd probably be the cheap plastic gear from the winding motor broke
very common MZ problem
07-30-2009, 01:06 PM   #3
Forum Member




Join Date: Aug 2008
Location: Dallas
Posts: 98
Original Poster
Is that a part that is inside, or one where I can see it? Is it fixable?

The camera winds the film around the take-up spool successfully. When I open the camera back, there is several inches wound around the take-up side already, and everything looks perfectly normal. Wouldn't that mean that the winding motor is working?
09-23-2009, 06:32 AM   #4
Junior Member
daivx's Avatar

Join Date: May 2009
Location: Chicago
Photos: Gallery
Posts: 25
Hi BetterSense, have you solved the film loading problem? I just come across the same problem, MZ-50, battery die when I shoot over 13 shots, soon the winding motor starts to work.
Film icon is blinking, I just opened the cover to find that the film was not yet winded. Of course, this film is exposed.
So I have to take the whole film out manually. The problem is that I put a new film in, 'E' starts to blink, dozen times tried as you descried, still the same.

10-03-2009, 07:54 PM   #5
Site Supporter
Nick Siebers's Avatar

Join Date: Jun 2008
Location: Madison, WI
Photos: Gallery | Albums
Posts: 2,152
It happened to me the first time I tried loading my ZX-5. The film was curled up a little, and too far in. I had to push it back into the cannister and lay it really flat. Hope it is working for you all!
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, film, mz-5
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Short film "Paddleboat Pirates" shot on Pentax K7s MangoFan Video and Pentax HDSLRs 1 03-10-2010 05:10 AM
"CHANGE" - a 48hr film challenge project, shot on K-X greenless Video and Pentax HDSLRs 6 02-16-2010 06:36 PM
Etymology: "judas window" in film camera SquintyEyes Pentax Film SLR Discussion 20 02-16-2010 02:43 PM
"Digitizing" Film: Options & Opinions drewdlephone Pentax Film SLR Discussion 21 01-06-2009 12:51 PM
"Hunger for a DA*50-135?" or "The DA*50-135 as a bird lens!" or "Iron age birds?" Douglas_of_Sweden Post Your Photos! 4 08-13-2008 06:09 AM



All times are GMT -7. The time now is 02:18 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top