Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-10-2009, 12:49 PM   #1
Senior Member
Black Magic's Avatar

Join Date: Jan 2009
Location: Regina, Saskatchewan, Canada
Posts: 107
Help! MZ-7 shutter release not working

I recently bought a used MZ-7 from Henry's on eBay. I am completely new to film photography, and the camera didn't come with a manual. It worked fine for 13 exposures, but now the shutter is not activating. A half-press activates the metering and autofocus/autofocus confirmation, but the camera will not actually take a picture. I have removed the batteries and put them back in and changed lenses, but can't really think of what else to do. The LCD isn't giving me any weird error messages. Does anyone have any suggestions?

08-10-2009, 04:03 PM   #2
Pentaxian
jimH's Avatar

Join Date: Apr 2009
Location: South Central Nebraska - USA
Photos: Gallery | Albums
Posts: 1,413
I'm not familiar with that camera, however you might try checking the AF.S - AF-C - MF switch. Also check if the Aperture ring is set on "A". Just a couple of things that might affect it. Hopefully someone knowledgeable about that camera will respond.
08-10-2009, 04:18 PM   #3
Senior Member
Black Magic's Avatar

Join Date: Jan 2009
Location: Regina, Saskatchewan, Canada
Posts: 107
Original Poster
Yes, all the dials, including the manual focus/auto-focus switch and the "A" setting on the aperture ring are in a definate spot that "snicks." Everything is working as it should, however the camera still isn't releasing the shutter. Could I just have bad luck, and the shutter puked on me right after my first 13 exposures with it? I just sent in a DA* 50-135 that needed to be replaced, not fixed under warranty. Hope I don't have to send in more of my equipment.
08-10-2009, 05:18 PM   #4
Pentaxian
Ratmagiclady's Avatar

Join Date: Nov 2008
Location: GA
Photos: Gallery | Albums
Posts: 13,464
I believe there are some conditions in some modes under which the MZ-7 won't release the shutter, like without AF confirmation or a valid exposure: I'm afraid I don't recall the details, but Photolady here was experiencing a problem like that.

The manual is online somewhere, not sure where. Pentax's own site, perhaps, and possibly orphancameras.com.

Are the batteries fresh, by the way?

08-10-2009, 07:23 PM   #5
Senior Member
Black Magic's Avatar

Join Date: Jan 2009
Location: Regina, Saskatchewan, Canada
Posts: 107
Original Poster
Yes the batteries are only 1 week/13 exposures old. I am getting focus confirmation, as the symbol appears, and I hear the beep. I should also mention that it stopped working while I was shooting objects, all of which were around the same exposure settings, so i'm not sure if the valid exposure thing applies.
08-10-2009, 07:38 PM   #6
Pentaxian
Just1MoreDave's Avatar

Join Date: Feb 2007
Location: Aurora, CO
Photos: Gallery | Albums
Posts: 4,814
I don't have any ideas, but here's the manual:

Pentax MZ-7, ZX-7 manual, user manual, free instruction manual, pdf manuals
08-11-2009, 06:52 PM   #7
Senior Member
Black Magic's Avatar

Join Date: Jan 2009
Location: Regina, Saskatchewan, Canada
Posts: 107
Original Poster
This might be a really dumb question, but should I be able to activtate the shutter when there is no film loaded? I rewound and took out the film after the camera stopped working, then tried testing it without film inside. Still no shutter
08-11-2009, 07:07 PM   #8
Pentaxian
jimH's Avatar

Join Date: Apr 2009
Location: South Central Nebraska - USA
Photos: Gallery | Albums
Posts: 1,413
QuoteOriginally posted by Black Magic Quote
This might be a really dumb question, but should I be able to activtate the shutter when there is no film loaded? I rewound and took out the film after the camera stopped working, then tried testing it without film inside. Still no shutter
I don't know, but maybe the user manual that one of the posters left the link for might give some of that information.

08-11-2009, 07:38 PM   #9
Damn Brit
Guest




Moving to Film forum where you should get an answer.
08-12-2009, 08:56 AM   #10
Veteran Member
AndrewG NY's Avatar

Join Date: Dec 2006
Location: Chappaqua, NY
Photos: Gallery
Posts: 676
You should be able to fire the shutter without film. A question: do you hear any noise at all when you press the shutter button? You may have encountered a somewhat common problem in MZ/ZX bodies where a plastic gear on the mirror motor cracks/breaks. The replacement part has a metal gear instead, though changing it is not super-easy. I have a ZX-5n which probably needs this surgery and it won't fire or invoke depth-of-field preview either; I hear a quiet buzzing noise when I hit the button, though I don't know if this is always the case. This camera worked intermittently when I first got it but I can no longer "make it work". Try looking at some of these threads.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, mz-7, shutter
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K20D Shutter Not Working!!! Murdoughnut Pentax DSLR Discussion 8 09-06-2010 11:40 PM
K10D shutter release button not working well . Any ideas lesmore49 Pentax DSLR Discussion 6 07-19-2009 10:48 PM
Why won't my ZX-7 let me release the shutter? photolady95 Pentax Film SLR Discussion 8 06-23-2009 11:50 AM
Lenses w/o an A - how to get the shutter working Iowa Tom Pentax DSLR Discussion 16 08-12-2008 01:30 PM
Shutter release not working K10 voicelit Pentax DSLR Discussion 10 06-05-2008 12:44 PM



All times are GMT -7. The time now is 09:36 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top