Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-31-2009, 02:14 PM   #1
Inactive Account




Join Date: Sep 2008
Location: lorne,nsw.australia
Posts: 14
MESuper

Hi,
Just picked up an ME Super,it has a few issues.Film advance stuck so I cant fire shutter(spell check just picked up typo error,dont hit key next to U for shutter).This was a problem with my Canon AE1 but a new battery fixed this,will this be the same for the super?
The mirror is in the up position but not stuck,push it down with no resistance but it just slowly rises back up,making the view finder dark,any thoughts most welcome
Thank you,Steve

08-31-2009, 02:27 PM   #2
Forum Member




Join Date: Aug 2008
Location: Dallas
Posts: 98
I have an old beat-up ME Super that locks up every now and then. I can fix it by taking the film out, and pushing the shutter curtain down with my fingernail.
08-31-2009, 06:47 PM   #3
Pentaxian




Join Date: Sep 2007
Location: Bay Village, Ohio USA
Posts: 1,047
ME Super

The ME Super needs a battery to operate the meter and the electronically controlled shutter. However, it is designed so that it can be used in B and at 1/100 (or is it 1/125?) second without battery power. Try setting it on 1/100. That's why there are the settings "M", "A", "1/100" and "B" on the selector dial.

I have an ME Super but I don't have it with me. I don't know if a dead battery will prevent the film advance from working. I'm afraid that I don't think it will, which would indicate something more seriously wrong.

Is the shutter open and the mirror up? Mine will occasionally stick in the open position when I shoot in Auto mode. When this happens, I change to 1/100 or Manual mode and it usually clears it up. Someone may have had this happen and left it that way, running the battery down in the process. You could try a new battery. They're not expensive.

BTW, if you don't have a user manual, you can download one for free from Pentax USA's website at PENTAX Digital Cameras and DSLRs - Official PENTAX Imaging Web Site. Click on the support button and then on "self support". Follow the links for manuals and literature. The manuals are mediocre photocopies in PDF form. The print quality is lousy, but the information is all there.
08-31-2009, 08:24 PM   #4
Veteran Member
frank's Avatar

Join Date: Nov 2006
Location: Singapore
Photos: Gallery
Posts: 3,202
1. Set the mode dial to 125x or B as suggested by Paul and see if the mirror comes down.
2. If not, try BetterSense's trick: open up the back door, put your finger lightly on the shutter (those hinges) and push it slightly down, this usually would work w/ stuck shutter/mirror.
3. If still no luck, try Wheatfield's trick here: https://www.pentaxforums.com/forums/pentax-film-slr-discussion/70158-super-program-issues.html

If still no luck, I guess the camera needs a trip to a repair shop, or Eric as suggested by many here.

08-31-2009, 08:25 PM   #5
New Member




Join Date: Jul 2009
Posts: 16
The ME super should definitely advance and be able to fire at it's default speed of 1/125 without a battery.

Don't try to force the winder, I would open the back and very gently try to push the shutter curtain down with your fingernail. In my experiences with multiple ME Supers this will put the mirror back down and let you advance. If it works the next you try to fire the shutter is a different story. You never know though, sometimes it just needs a good restting of the firing sequence.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale - Sold: Spotmatic SP-F w/ SMC 55mm/1.8, K2, MESuper, NIB MESuper Soft Case monochrome Sold Items 9 12-05-2009 11:15 AM



All times are GMT -7. The time now is 07:56 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top