Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-21-2009, 11:05 AM   #1
Inactive Account




Join Date: Sep 2009
Posts: 1
new kid

hi everybody,
my name is dale and i have recently taken up photography and am in a spot of bother . I bought an sfx camera and on my third roll of film it would no longer load the film on, all it does is make a horrible noise. Has anybody ever come across this or know how to fix it? any help would be much appreciated.

regards,
dale

09-21-2009, 07:03 PM   #2
Veteran Member
frank's Avatar

Join Date: Nov 2006
Location: Singapore
Photos: Gallery
Posts: 3,202
Hi Dale,

Welcome to the forum

Sorry to hear the problem w/ your SFX. I'm guessing it's the winder motor got problem, or some part between the motor and the winder. I know it's one of the know problem for MZ series cameras (except the MZ-S), one of the plastic part got broken. To repair this might cost quite some money, probably don't worth it 'cause you can get another perfect working one for less than 30 or 50usd.

Good luck.
09-24-2009, 09:40 AM   #3
Senior Member




Join Date: Jul 2008
Location: South Carolina, USA
Posts: 276
The battery could be getting old. Try replacing it (it's in the right hand grip) and see what happens.
09-24-2009, 04:48 PM   #4
Pentaxian
Ratmagiclady's Avatar

Join Date: Nov 2008
Location: GA
Photos: Gallery | Albums
Posts: 13,470
Also, try fussing with the rewind switch (when there's no film in the camera,) and any buttons relating to loading.)

I'm relying on some very old memory, but I think some cameras of that type body and era had an issue that way. Basically, the camera may still think it's trying to wind back into the cartridge, rather than loading the next roll. )

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
dale, film
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
our kid sashe3320 Non-Pentax Cameras: Canon, Nikon, etc. 1 11-01-2010 09:22 PM
New kid in town, well not really a kid. natimmas Welcomes and Introductions 2 08-21-2010 01:02 PM
A kid in Tibet fractal Post Your Photos! 2 02-01-2009 01:58 PM
Kid Portriats dermc Post Your Photos! 12 11-15-2008 10:10 AM
New E40 for my kid ChrisPlatt Pentax Compact Cameras 3 08-20-2008 03:48 AM



All times are GMT -7. The time now is 10:15 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top