Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-14-2007, 12:23 AM   #1
Veteran Member




Join Date: Sep 2006
Location: Melbourne, Australia
Posts: 423
My ME Super has arrived

Hi all,

Just received my first ever manual camera today, Pentax ME Super! I knew it was coming (thanks to online tracking) so I brought a roll of film and my M50/1.7 with me today. After following the manual carefully I was able to got everything working properly. However I am finding the Exposure Mode Index button (the one you use to change the camera into Auto, M, 125x, B or Lock) very stiff to turn. I think it might be caused by the white button not depressing properly, sometimes it get stuck in the depressed state and doesn't come back up.

Now here are my questions:

1. Is this normal (due to age of the camera)?

2. Can this be fixed easily? Ie can I just bring this into a camera shop and they will be able to fix it without too much trouble?

3. If I am going to get it fixed, assuming the problem is fixable, anything else I should get the shop to check?

4. Anything else I should watch out for?

Thanks
Kenny

06-14-2007, 03:43 AM   #2
Veteran Member




Join Date: Sep 2006
Location: Melbourne, Australia
Posts: 423
Original Poster
Some photos of ME Super

Just thought I would post some photos of the camera itself

1


2


3


4


5


cheers
Kenny
06-14-2007, 09:14 AM   #3
J2R
Junior Member




Join Date: Jun 2007
Location: Norwich, UK
Posts: 43
I always found the dial stiff to turn on my ME Super. I decided it was a design feature.
06-14-2007, 09:45 AM   #4
Inactive Account




Join Date: Mar 2007
Photos: Gallery
Posts: 3,675
I bought my ME Super new back in the day and it has always been a bit stiff to turn. I was never concerned about it - maybe I should have been. They are great little (tiny SLR, isn't it?) cameras and I never plan on selling mine.

If you haven't done it already, check the foam seals on the back and the mirror dampening foam. If they haven't been replace they will probably look ragged and need replacement. I can recommend a replacement product if you want.

06-14-2007, 06:15 PM   #5
Veteran Member




Join Date: Sep 2006
Location: Melbourne, Australia
Posts: 423
Original Poster
Hi

Latest update, my mode dial is stuck at "L" position! Do'h! Of all the modes, it got stuck at "L". Now I can't take photos nor can I rewind the film in the camera! I am currently in contact with keh.com since I just received the camera from them yesterday. I am also taking it to a local shop to see how much to fix it (I am in Australia so if I need to pay the shipping to send it back, I might as well spend it on fixing it).

And yes, ME Super is tiny (ok maybe not tiny but it is definitely small!). The viewfinder is huge too, almost too big for me since I wear spectacles.

cheers
Kenny
06-15-2007, 06:26 PM   #6
Forum Member




Join Date: Sep 2006
Location: Vancouver, BC
Posts: 81
I just got a ME Super yesterday with the 50mm f/1.7. Coincidence?

One of my previus ME Supers had the sticky control dial. The white button was partially depressed. I used a pointy but soft piece of plastic to push down a little on the white button and the dial unlocked. Everything worked fine after that.
06-18-2007, 05:28 PM   #7
Veteran Member




Join Date: Sep 2006
Location: Melbourne, Australia
Posts: 423
Original Poster
ME Super fixed!

Ok I finally got my camera fixed locally and I have still yet to hear a reply from keh.com! I didn't even get an automated reply from them to acknowledge that they have received my email. Hmm.. keh.com has been good in my past dealings with them so I will give them a couple of days before I pass my judgement (sent my email to them on Thursday night Melb, Australia time (so Thursday morning US time I believe)).

Anyway, the stuck dial was caused by, <drum rolls>, rust! Aparently according to the camera repair guy, the mechanism underneath the dial was so rusted out that it wouldn't turn anymore. Luckily he got some spare parts to replace it. I dropped the camera off to them on Friday lunchtime and got it back on Monday after work so a very speedie job. All I need to do now is get my half-roll of film developed to see how they turn out! (Half roll because camera stopped working half way and the technician had to rewinded the film to fix the camera).

cheers
Kenny
07-06-2007, 02:15 PM   #8
New Member
tyto's Avatar

Join Date: Jul 2007
Location: California
Posts: 1
QuoteOriginally posted by J2R Quote
I always found the dial stiff to turn on my ME Super. I decided it was a design feature.
This was my impression, too. I have two ME Super SEs; one bought new 23 years ago and another through eBay around five years ago. The dials on both were always noticeably stiffer than, for example, those on the Super Program or Program Plus. But rust, well. . . . Glad your shop had the parts.

The button on the dial will stay depressed in some modes (Auto and manual, IIRC) to allow for more easy switching among them--it's actually a blessing, as the button is way too small. Pentax must have realized this, given the much larger button on the Super Program and Program Plus.

Even as I've begun to consider the K10D, I've no thought of getting rid of the MEs. They're true workhorses.

P.S.: How did your half-roll of pics turn out?

Edit: sorry to point out the obvious--I didn't realize that I was viewing the newer responses first.

10-08-2007, 04:13 PM   #9
Senior Member




Join Date: Oct 2007
Location: GTA Ontario Canada (Tottenham Area)
Posts: 138
Hi all, I picked up a ( new to me ) ME super on Sat. I replied to an add on Kijiji. Long story short the guy was selling it for his sister for 45.00. Anyway he was tired of trying to move it and wanted his sister to take it back. She just told him get rid of it. So before I could arrange a time to have a look he emailed me back " it's on the front deck in a bag, come get it".








Anyway I now have a nice clean ME super with a 50mm f2.0 SMC lens. It's not the 1st Pentax I have owned and I wish I had kept some of the other lenses. Just need to find the cover for the motor drive port to keep the dust and dirt out.

Oh the mode selector knob is not difficult to move but not loose either. The white button stays down when it is set to anything but auto and when you rotate the dial through auto it pops up and locks.

Last edited by fastoys2nv; 10-09-2007 at 05:35 AM.
10-08-2007, 04:30 PM   #10
Inactive Account




Join Date: Mar 2007
Photos: Gallery
Posts: 3,675
QuoteOriginally posted by fastoys2nv Quote
Just need to find the cover for the motor drive port to keep the dust and dirt out.
If you are talking about a 'winder cap'. I bought one from this seller on Ebay. It fit my ME super perfectly!
10-08-2007, 04:44 PM   #11
Senior Member




Join Date: Oct 2007
Location: GTA Ontario Canada (Tottenham Area)
Posts: 138
Yep that's the cap I am looking for. Thanks
11-04-2007, 05:54 PM   #12
New Member
Top_Gun's Avatar

Join Date: Aug 2007
Location: South Carolina
Posts: 9
I recently got mine off ebay back in summer for good price..

same comparsion here...with the white mechanism ....

just depress with finger or safe object... and all is good...

Looking forward to using it more ...took some Dirt track racing pics over the weekend

anxious to see how this "workhorse" will work out
11-17-2007, 04:44 PM   #13
New Member
wingcmdr's Avatar

Join Date: Oct 2007
Location: Philippines
Posts: 5
My ME

QuoteOriginally posted by fastoys2nv Quote
Hi all, I picked up a ( new to me ) ME super on Sat. I replied to an add on Kijiji. Long story short the guy was selling it for his sister for 45.00. Anyway he was tired of trying to move it and wanted his sister to take it back. She just told him get rid of it. So before I could arrange a time to have a look he emailed me back " it's on the front deck in a bag, come get it".








Anyway I now have a nice clean ME super with a 50mm f2.0 SMC lens. It's not the 1st Pentax I have owned and I wish I had kept some of the other lenses. Just need to find the cover for the motor drive port to keep the dust and dirt out.

Oh the mode selector knob is not difficult to move but not loose either. The white button stays down when it is set to anything but auto and when you rotate the dial through auto it pops up and locks.
Hi Guys,


I have an ME very mint with motor drive because I bought it collecting dust from a local dealer.

It's a very nice machine and I'm proud of owning it.

It came with the SMC 50mm f1.7 Lens.

This week I will be able to acquire a mint condition MV with a motor drive and Program Plus model for a steal.

I intend to keep the Program Plus for myself and give the MV to my niece as a gift for Lomography.

Back in the day these models may not be top of the line, but for the specific purpose that I intend to use it for, it's a great machine.


Marl
12-05-2007, 12:33 PM   #14
Veteran Member
titrisol's Avatar

Join Date: Dec 2007
Location: In the most populated state... state of denial
Photos: Gallery | Albums
Posts: 1,094
The week of the MEsuper.. just got one myself, and a MG from a colleague that went digital
Put fresh batteries, got the manual from Kim Coxon's site and the camera powered and began shooting.
I'll pick up the 1st roll tomorrow.... now to get more pentax M and A lenses......

Update: 10/12 Got the roll back everything seems to be A-OK

Last edited by titrisol; 12-17-2007 at 04:39 PM.
02-25-2008, 12:26 AM   #15
Veteran Member
titrisol's Avatar

Join Date: Dec 2007
Location: In the most populated state... state of denial
Photos: Gallery | Albums
Posts: 1,094
Well got my film back, and I have to say the camera performs as good as any other one
The paddles are a bit awkward at the beginning but after a while they become quite useful.

I put my old Takumar 17/4 fisheye with an adapter and got very nice pics
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
button, camera, shop, thanks
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
I've Arrived! daylightsteam4449 Welcomes and Introductions 2 02-21-2010 04:18 AM
new tammy just arrived 9thumbs Post Your Photos! 2 03-14-2009 03:54 PM
k,m 50 arrived gpaual Post Your Photos! 0 04-30-2008 05:45 PM
My New DA 10-17 has arrived Fl_Gulfer Pentax SLR Lens Discussion 15 02-25-2008 06:46 PM
My 77 Ltd. Has Arrived! balofagus Pentax SLR Lens Discussion 12 02-09-2007 09:59 PM



All times are GMT -7. The time now is 10:09 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top