Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-15-2009, 10:01 AM   #1
New Member




Join Date: Dec 2009
Location: Brighton
Posts: 3
P30 Wind Lever Doesn't Wind Complete Cycle - Any ideas?

Hi All,

I am seeking help regarding a problem I'm having with my P30. Basically, the wind lever goes about 1/3 (maybe a bit less) of the way around and then stops.

It just feels like something is stopping it and I've got no idea what. I was hoping to get help from here as the camera people in Brighton want to charge me 28 quid just to look at it.

The counter is saying 'S', if that helps? And, there is no film in it right now. I can't think what else I need to say.

If anyone has any ideas whatsoever I would appreciate it greatly.

Thanks for reading this.

Dan

12-15-2009, 10:21 AM   #2
Pentaxian
ryan s's Avatar

Join Date: Jan 2008
Location: Madison, WI
Photos: Gallery
Posts: 2,370
Try new batteries
12-15-2009, 11:10 AM   #3
Veteran Member
keyser's Avatar

Join Date: Aug 2009
Location: Tsawwassen, BC
Posts: 376
My thought is; does this model of camera wind when there's no film? I'm not sure why they'd prevent it, but it's worth concideration.
12-15-2009, 12:15 PM   #4
Pentaxian
ryan s's Avatar

Join Date: Jan 2008
Location: Madison, WI
Photos: Gallery
Posts: 2,370
QuoteOriginally posted by keyser Quote
My thought is; does this model of camera wind when there's no film? I'm not sure why they'd prevent it, but it's worth concideration.
I have a P3 sitting here that requires batteries for the winder to even move. I'm not sure about the P30(T) requiring film, although these two cameras are basically brothers...

12-15-2009, 01:09 PM   #5
New Member




Join Date: Dec 2009
Location: Brighton
Posts: 3
Original Poster
Ok, great. I'm gonna try that. I'll get some new batteries asap and try it.

There's no film in it too so i'll whack some in there as well. Fingers crossed we should have a working camera!

I'll let you know.

Cheers, it's much appreciated!
12-15-2009, 02:51 PM   #6
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 26,202
QuoteOriginally posted by ryan s Quote
I have a P3 sitting here that requires batteries for the winder to even move. I'm not sure about the P30(T) requiring film, although these two cameras are basically brothers...
I seem to remember something about this in an ancient post. The winder lock will not release unless the shutter is operable (i.e. good battery). Is my memory correct Ryan?

Steve
12-15-2009, 02:53 PM   #7
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 26,202
QuoteOriginally posted by keyser Quote
My thought is; does this model of camera wind when there's no film? I'm not sure why they'd prevent it, but it's worth concideration.
It is manual wind with no motor. As such, the winder must be operable to even put film in the camera. (This does not apply to Canon QL cameras )

Steve
12-15-2009, 06:22 PM   #8
Pentaxian
ryan s's Avatar

Join Date: Jan 2008
Location: Madison, WI
Photos: Gallery
Posts: 2,370
QuoteOriginally posted by stevebrot Quote
I seem to remember something about this in an ancient post. The winder lock will not release unless the shutter is operable (i.e. good battery). Is my memory correct Ryan?

Steve
Yep! The camera acts as if the shutter is cocked but stuck. Winding lever comes off the body a little...the shutter button feels stuck...the shutter curtains are in the "rest" position. Mirror is down like normal, however.

Basically...all the signs of a stuck shutter upon initial inspection

12-16-2009, 03:56 AM   #9
Pentaxian
titrisol's Avatar

Join Date: Dec 2007
Location: In the most populated state... state of denial
Photos: Gallery | Albums
Posts: 1,094
probably the shutter is "loaded"but can not trigger due to lack of batteries

The P30t (at least the one I got) can shoot with no film, and can wind with no batteries
12-16-2009, 06:38 AM   #10
New Member




Join Date: Dec 2009
Location: Ljubljana, Slovenia
Posts: 9
The P30 shutter won't release without batteries. Give it some fresh battery infusion, and it will snap like a tiger
12-16-2009, 10:10 AM   #11
Forum Member




Join Date: Mar 2007
Location: Finland
Posts: 70
Or it is jammed... My P30n is jammed in a similar way...
12-16-2009, 10:46 AM   #12
New Member




Join Date: Dec 2009
Location: Brighton
Posts: 3
Original Poster
Thank you all so much for your help, what a great forum to come for advice.

It's working again now. I bought some new batteries and it started 'snapping like a tiger' in no time.

You were right. It's a manual wind but without batteries the shutter wouldn't work so the wind wouldn't work.

Solved!
12-16-2009, 11:03 AM   #13
New Member




Join Date: Dec 2009
Location: Ljubljana, Slovenia
Posts: 9
Glad it's working now. It's a lovely little camera. Always keep mine in the bag, just in case I go all sentimental about film chemistry
08-29-2015, 08:58 AM   #14
New Member




Join Date: Aug 2015
Posts: 1
Hi there,

I just bought a used pentax p30 and unfortunately I noticed that the lever does not wind more than half way. I tried everything and it still does not work
do you have any ideas I could try?

Thank you,
rebus
08-31-2015, 06:08 AM   #15
Pentaxian
titrisol's Avatar

Join Date: Dec 2007
Location: In the most populated state... state of denial
Photos: Gallery | Albums
Posts: 1,094
You can try "resetting" the camera
See instructions here:
Favorite Classics / Resetting cameras
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
lever, p30, wind
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
People In the wind devisor Post Your Photos! 3 11-11-2009 05:53 AM
LX Wind Lever Cap SOldBear Pentax Film SLR Discussion 4 07-15-2009 08:27 PM
into the wind... dcmsox2004 Post Your Photos! 6 06-26-2009 05:02 AM
Into the wind creampuff Post Your Photos! 7 12-29-2008 10:32 PM
Me-super rapid wind lever not returning properly Heldur Pentax Film SLR Discussion 13 10-10-2008 12:45 AM



All times are GMT -7. The time now is 08:46 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top