Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-19-2010, 09:17 PM   #1
Forum Member




Join Date: Nov 2009
Location: United States
Photos: Gallery
Posts: 50
ZX-5n multi-seg metering problem

I have a ZX-5n that works fine in center-weighted and spot metering mode, but reads 6-7 f/stops high (overexposed) in multi-segmented metering mode. Is this likely to be a bad circuit board, or could it be the switch ? Is the metering control board separate or part of the mother board ? I'm wondering if I might scavenge a replacement part from a ZX-5, ZX-10, or other ZX / MZ series body ? Thanks for any tips...

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
board, mode, zx-5n
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Linking AF point and AE during multi-seg metering geckogrin Pentax DSLR Discussion 3 08-21-2010 07:59 PM
Multi spot metering mymage Pentax DSLR Discussion 15 06-04-2010 09:50 PM
K20 multi metering ? FHPhotographer Pentax DSLR Discussion 8 08-15-2009 08:41 PM
multi-segment metering and M lenses newarts Pentax DSLR Discussion 11 03-09-2009 01:45 PM
multi segmented metering dwssas Pentax DSLR Discussion 9 03-22-2008 07:10 AM



All times are GMT -7. The time now is 01:44 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top