Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
5 Likes  
Sigma 50-150 F2.8 EX DC HSM II Refurbished- $499 at Sigma Outlet
Posted By: seventysixersfan, 03-01-2013, 01:45 PM

WOW!

These won't last long, I'm sure. $499 for the awesome and rare Sigma 50-150 F2.8 EX DC HSM II.
50-150mm F2.8 EX DC HSM II Refurbished | Sigma

Last time it was offered in the Sigma Outlet Store was for $559.

As discussed here in this thread:
https://www.pentaxforums.com/forums/pentax-price-watch/195883-refurbished-si...nses-sale.html

And Edgar does an excellent write-up of this lens here:

https://www.pentaxforums.com/forums/lens-sample-photo-archive/196246-sigma-5...es-thread.html
https://www.pentaxforums.com/forums/pentax-slr-lens-discussion/128533-sigma-...lots-pics.html

Run, don't walk, to buy this great zoom lens at an amazing price!

Attached Images
 


Last edited by seventysixersfan; 03-01-2013 at 01:53 PM.
Views: 30,775
03-19-2013, 12:29 PM   #166
Pentaxian
seventysixersfan's Avatar

Join Date: Aug 2010
Location: Alexandria, VA
Posts: 1,698
Original Poster
QuoteOriginally posted by skamalpreet Quote
Received the lens back along with my K5. Apart from the beautiful packaging these sent the two in no change. I am still dialling in -10 to the same effect. Wondows what calibration was carried out by Sigma. Total waste of time and money.
Well that's very disappointing to hear. All the other posts on this forum about Sigma's calibration services have been positive, so I wonder why yours was the exception?

03-19-2013, 12:34 PM   #167
Loyal Site Supporter




Join Date: Jul 2010
Location: Blue Ridge Escarpment, North Carolina, US
Photos: Gallery | Albums
Posts: 1,282
gda13,
Just received mine back yesterday in double walled corrugated box cushioned to beat any packing I've seen in a long time. "REPAIRED", adjusted the AF data, (+5, +10)
updated the firmware
Fast turnaround, fully insured return, I'm impressed Sigma!
03-19-2013, 01:21 PM   #168
Site Supporter
gda13's Avatar

Join Date: Aug 2010
Location: Florida
Photos: Gallery | Albums
Posts: 879
QuoteOriginally posted by lukulele Quote
gda13,
Just received mine back yesterday in double walled corrugated box cushioned to beat any packing I've seen in a long time. "REPAIRED", adjusted the AF data, (+5, +10)
updated the firmware
Fast turnaround, fully insured return, I'm impressed Sigma!
Excellent! And how about the results...?
03-19-2013, 02:08 PM   #169
Loyal Site Supporter




Join Date: Jul 2010
Location: Blue Ridge Escarpment, North Carolina, US
Photos: Gallery | Albums
Posts: 1,282
QuoteOriginally posted by gda13 Quote
Excellent! And how about the results...?
Haven't even had a chance to do anything other than open the box. I'll take it over to the Norfolk Southern mainline later this evening.

03-19-2013, 02:50 PM   #170
Senior Member




Join Date: Jun 2009
Location: Sydney
Posts: 146
QuoteOriginally posted by lukulele Quote
gda13,
Just received mine back yesterday in double walled corrugated box cushioned to beat any packing I've seen in a long time. "REPAIRED", adjusted the AF data, (+5, +10)
updated the firmware
Fast turnaround, fully insured return, I'm impressed Sigma!
Where did it say "REPAIRED", adjusted the AF data, (+5, +10)
I received mine without anything of the sort
03-19-2013, 02:51 PM   #171
Senior Member




Join Date: Jun 2009
Location: Sydney
Posts: 146
QuoteOriginally posted by seventysixersfan Quote
Well that's very disappointing to hear. All the other posts on this forum about Sigma's calibration services have been positive, so I wonder why yours was the exception?
I am susprised as well. Totally disappointed
03-19-2013, 03:39 PM   #172
Pentaxian
Edgar_in_Indy's Avatar

Join Date: May 2010
Location: Indiana, USA
Photos: Gallery
Posts: 2,554
QuoteOriginally posted by skamalpreet Quote
Received the lens back along with my K5. Apart from the beautiful packaging these sent the two in no change. I am still dialling in -10 to the same effect. Wondows what calibration was carried out by Sigma. Total waste of time and money.
I'm also surprised to hear that. I wonder if they somehow forgot to calibrate yours. Since it sounds like they have probably gotten several of these in at once to work on, maybe yours fell through the cracks? I would contact them and let them know, and ask if they can email you a UPS label to pay for the return shipping since the problem wasn't fixed.

Also, for anybody sending your body in for calibration, it may be a good idea to reset your calibration for the 50-150mm back to zero first.
03-19-2013, 05:02 PM   #173
Loyal Site Supporter




Join Date: Jul 2010
Location: Blue Ridge Escarpment, North Carolina, US
Photos: Gallery | Albums
Posts: 1,282
All of this was verbatim on the work order/ packing sheet. I just created an album (my only one) with three quick unaltered shots via iPhoto as our outside light was disappearing. Mine went to Sigma USA in NY state. I'm out of attachment space so it was only way to get something up as a sample.

03-19-2013, 05:16 PM   #174
Senior Member




Join Date: Jun 2009
Location: Sydney
Posts: 146
QuoteOriginally posted by Edgar_in_Indy Quote
I'm also surprised to hear that. I wonder if they somehow forgot to calibrate yours. Since it sounds like they have probably gotten several of these in at once to work on, maybe yours fell through the cracks? I would contact them and let them know, and ask if they can email you a UPS label to pay for the return shipping since the problem wasn't fixed..
I find that difficult to digest since I called them twice and they said that the technician was looking at it...the one with the red camera bag ( I have a red camera bag)

QuoteOriginally posted by Edgar_in_Indy Quote
Also, for anybody sending your body in for calibration, it may be a good idea to reset your calibration for the 50-150mm back to zero first.
Ditto...did that.

Have a good mind to call Sigma and speak to them
03-19-2013, 05:20 PM   #175
Site Supporter
gda13's Avatar

Join Date: Aug 2010
Location: Florida
Photos: Gallery | Albums
Posts: 879
QuoteOriginally posted by skamalpreet Quote
Where did it say "REPAIRED", adjusted the AF data, (+5, +10)
I received mine without anything of the sort
They emailed me a document entitled "Acknowledgement" that is basically a copy of the online work order that I submitted with the additional details of what they did and the tracking number for the return shipment. Since I have not received my gear yet I cannot confirm...but will do so once I have it.

QuoteOriginally posted by lukulele Quote
All of this was verbatim on the work order/ packing sheet. I just created an album (my only one) with three quick unaltered shots via iPhoto as our outside light was disappearing. Mine went to Sigma USA in NY state. I'm out of attachment space so it was only way to get something up as a sample.
Thanks for sharing!
03-19-2013, 05:28 PM   #176
Site Supporter
gda13's Avatar

Join Date: Aug 2010
Location: Florida
Photos: Gallery | Albums
Posts: 879
QuoteOriginally posted by skamalpreet Quote
I find that difficult to digest since I called them twice and they said that the technician was looking at it...the one with the red camera bag ( I have a red camera bag)



Ditto...did that.

Have a good mind to call Sigma and speak to them

That does seem strange...I never had to use Debug mode myself but perhaps you might have to try it...unless for certain it is an issue with the lens itself and not the camera. But yes I would call them and see if they have anything specific to say regarding their calibration of your lens. Maybe you can request to speak with the technician?

https://www.pentaxforums.com/forums/pentax-k-5/197580-k5-focus-issues.html
03-19-2013, 05:41 PM   #177
Senior Member




Join Date: Jun 2009
Location: Sydney
Posts: 146
QuoteOriginally posted by gda13 Quote
They emailed me a document entitled "Acknowledgement" that is basically a copy of the online work order that I submitted with the additional details of what they did and the tracking number for the return shipment. Since I have not received my gear yet I cannot confirm...but will do so once I have it.
Well I did not receive any e-mail or communication of that sort nor a tracking number. The packaged just appeared 'One fine day'

Maybe they did miss working on my camera /lens. How frustrating....let me saee what they have to say tomorrow....will post it...tough luck...I am having a harrowing time since I bought the lens....not sure if they will allow me to return it now that the 15 days time has passed
03-19-2013, 06:05 PM   #178
Veteran Member
selar's Avatar

Join Date: Jul 2007
Location: Sydney, Australia
Photos: Gallery | Albums
Posts: 2,035
QuoteOriginally posted by skamalpreet Quote
sent my 3 week old K5 with the lens to sigma to be recalibrated....Fedex ground...have never done this before....praying that it comes back in good shape.....now I am wondering if I should have just let meself be contended with softer pictures....idiot ...idiot....why did you have to send the camera with the lens...pray pray it comes back in one piece,,,,
I am asking as your location says Melbourne, did you send the lens for calibration to Sigma Australia or Sigma US?
03-19-2013, 06:14 PM   #179
Pentaxian
jsherman999's Avatar

Join Date: Dec 2007
Photos: Gallery
Posts: 8,228
QuoteOriginally posted by seventysixersfan Quote
Not that this lens needs any more promotion, but here's a thread from a while back that compares the DA* 50-135 with the Sigma 50-150.

https://www.pentaxforums.com/forums/pentax-slr-lens-discussion/53035-sigma-5...-shootout.html
Neat to see my 4-year old thread referenced still

It's too bad about he downlevel firmware, but if you get a fully compatible copy, it can be a truly fantastic zoom.
Mine's still going strong 4 years later, and it's so good I kept it to shoot on full frame - even though it's an
aps-c lens. It's smaller/lighter than a 70-200 2.8, focuses fast and is very sharp, at least my copy is.
Highly recommended, even for more than $499.

Here are some examples on Full Frame (shot in DX (aps-c) mode on D800) :

.
75mm @ f/2.8




150mm @ f/2.8

.

Note: This lens, while stellar, has a weakness - near MFD, it often misses focus. If you're shooting near MFD and you wonder why it's not looking sharp, kick it in to MF and try again. At a few meters and beyond, problem seems to go away. (see my old thread linked above for details.)

.

Last edited by jsherman999; 03-19-2013 at 06:21 PM.
03-19-2013, 06:19 PM   #180
Senior Member




Join Date: Jun 2009
Location: Sydney
Posts: 146
QuoteOriginally posted by selar Quote
I am asking as your location says Melbourne, did you send the lens for calibration to Sigma Australia or Sigma US?
Sorry should have changed m location long time back. I am in US right now and sent it to Sigma US in NY.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
dc, dc hsm ii, f2.8, f2.8 ex dc, hsm, ii, lens, outlet, pentax deals, sigma, sigma 50-150 f2.8
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sigma 50-150mm f/2.8 II EX DC APO HSM Lens Samples Thread Edgar_in_Indy Lens Sample Photo Archive 48 11-03-2016 09:39 AM
Wanted - Acquired: Sigma 17-50mm f2.8 EX DC HSM -or- 24-70mm f2.8 EX DG HSM AirBoss Sold Items 8 05-20-2012 06:52 AM
For Sale - Sold: Sigma 50-150mm f2.8 APO EX DC HSM ivoire Sold Items 4 01-11-2012 07:15 AM
Sigma EX 50-150/2.8 II APO DC HSM Pentax gkopeliadis Pentax SLR Lens Discussion 4 03-18-2008 04:27 AM



All times are GMT -7. The time now is 04:14 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top