Forgot Password
Pentax Camera Forums Home
 

Showing results 1 to 2 of 2 Search:
Forum: Pentax Film SLR Discussion 01-07-2015, 11:09 PM  
K1000 - film advance lever clicking, film wont budge.
Posted By hiddenvibe
Replies: 6
Views: 2,637
Hi everyone,

I apologise if this is not the right place to be posting this, and for my poor use of terminology.

I've recently come into possession of a K1000. It's been working fine, but on a few rolls of film it has gotten stuck.

These particular rolls are quite sticky you could say and take some force to wind in-between shots.

They will then reach a point where they seem to be too hard to advance for the camera, and the wind lever will just click over, as if the gears do not have enough traction.

That is to say I am able to cock the shutter but the film will not advance.

Does anyone know if this is a common problem, and what causes it?

Is it easily fixed?

Thanks for reading.
Forum: Welcomes and Introductions 01-07-2015, 10:26 PM  
Hello!
Posted By hiddenvibe
Replies: 4
Views: 591
Hi everyone,

I am a brand new owner of a Pentax k1000. Hoping to connect with the community here to share photos and solve issues.

Thanks :)
Search took 0.00 seconds | Showing results 1 to 2 of 2

 
Forum Jump


All times are GMT -7. The time now is 11:53 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top