Forgot Password
Pentax Camera Forums Home
 

Showing results 1 to 25 of 300 Search:
Forum: Pentax K-3 07-10-2014, 09:34 AM  
Sigma 18-35 f1.8 - B&H shipping
Posted By dbh
Replies: 45
Views: 5,941
I used the K3 feature which allows a per-lens adjustment. None of my other lenses needed anything, so this is the first one in the K3's memory. I can confirm that it applies it only to this lens and not any of my other Sigma lenses (the 8-16 and the 50-500) which is a relief. I'm good to go. :)
Forum: Pentax K-3 07-10-2014, 07:41 AM  
Sigma 18-35 f1.8 - B&H shipping
Posted By dbh
Replies: 45
Views: 5,941
I checked this lens out last night after Dons brought one in for me from their Winnipeg store. Very nicely built. 7 yr Canadian warranty, too.
Ended up buying it. Got home to find a new f/w for the K3 was just out. Quickly updated that and snapped a few test shots with the new Sigma. Turned out to need an autofocus tweak (-6) but after that did a real nice job. Nothing worth posting here yet, but I think this lens will spend a lot of time on my K3.
And kudos to Dons Photo for overnighting one for me to check out - didn't even ask me for a deposit.
Forum: Pentax K-3 05-16-2014, 07:37 PM  
K3 sample shots ... post here !
Posted By dbh
Replies: 9,078
Views: 1,063,281
Nice photo!
Forum: Pentax K-3 05-14-2014, 07:03 AM  
Here's a weird one
Posted By dbh
Replies: 13
Views: 1,512
I do like that Sigma 180mm macro lens, though. 99% of the time it's on a tripod, manually focused, manual exposure, and lit with 2 or more strobes, so this quirk is easy to live with for me.
I understand Pentax had a 200mm macro that was good, but alas no longer available.
Forum: Pentax K-3 05-13-2014, 01:07 PM  
Here's a weird one
Posted By dbh
Replies: 13
Views: 1,512
If I think about it again, or encounter it again, I might do some investigating. The weird part to me was the influence the flash unit had on the camera's ability to read the lens. Not a big deal.
Forum: Pentax K-3 05-13-2014, 07:51 AM  
Here's a weird one
Posted By dbh
Replies: 13
Views: 1,512
I had my Metz 58 AF2 switched on and attached to the K3, and the Sigma 180mm macro attached. Turned on the camera and it asked me to enter the focal length!
Huh?
Turned the K3 off, back on, and it asked me for the focal length again. Turned it off, turned the flash off, turned the camera on - no more asking. Then turned on the flash, and proceeded to take my photos, all of which were perfectly exposed.
Hadn't thought about this little event until this morning when reading about some of the quirks people have been finding with their K3 reminded me.

I chalk it up to too many non-Pentax accessories.
Forum: Pentax News and Rumors 05-09-2014, 12:41 PM  
Sigma 18-35mm F1.8 Coming for Pentax!
Posted By dbh
Replies: 1,185
Views: 170,209
I keep checking this thread for the same reason. I suspect when there is some news on the availability of this lens, or it actually starts showing up somewhere, the thread may then get back on topic.
Forum: Pentax K-3 04-15-2014, 01:24 PM  
New K3's on the way!
Posted By dbh
Replies: 16
Views: 2,432
I, too, used a K10D/K20D pair right up until last year, when I replaced them with a K5iis/K3 pair.
I almost never used TAv mode before, now it's my go-to mode almost exclusively indoors. I'm happy to let the ISO rise up well past 6400 if needed. The grain is not bad and I never see banding problems.

These are nice cameras!
Forum: Pentax K-3 04-10-2014, 01:14 PM  
My K3 arrived to-day
Posted By dbh
Replies: 13
Views: 1,093
Hi and welcome. Your enthusiasm is evident, and refreshing! I think you will get good results from that zoom and after a few months of use you can look back at the photos and see what your favourite focal lengths are - and consider a nice high quality prime or 2 at those most used FLs. My favourite primes are the DA15, DA35 macro and DA70 limiteds. For some macro scenarios I am glad I have the Sigma 180 Macro. I also like to use an off-camera flash (or 2) when doing macros, but then I enjoy playing around with lighting.
Have fun! And don't be shy to post some photos...
Forum: Pentax K-3 03-29-2014, 11:31 AM  
K-3 Power-on issue
Posted By dbh
Replies: 141
Views: 17,253
Got my camera back from the shop yesterday. Shipped out Feb 17. On the paperwork returned with the camera:
"Body: cleaned and adjusted; Grip: tested- found to be in good working order."
There was no mention of it, but It had been updated to firmware 1.03 and of course now works perfectly - turns on every time.
I just finished putting back all my customizations one by one. Except for the file number being reset to 1, it's as good as before. Don't know what they "cleaned and adjusted" but at least it didn't seem to cause any problems. Big relief here and this thread can now work its way into the historical archives.
Cheers!
Forum: Pentax K-3 03-10-2014, 06:51 AM  
K-3 Power-on issue
Posted By dbh
Replies: 141
Views: 17,253
My faith waned after 1.01 and failed after 1.02.
It has now been restored. Good thing I'm not waiting for the mirror flop issue fix.
Forum: Pentax K-3 03-09-2014, 01:07 PM  
K-3 Power-on issue
Posted By dbh
Replies: 141
Views: 17,253
I was on the horns of a dilemma - initially I was sure the problem would be widespread and would be addressed by the first f/w update.
2 updates later, and not seeing a lot of talk besides this thread, and hearing from Pentax that this was the first they'd heard of it, I thought to myself even if it was fixable via software, if Pentax never gets it pointed out to them, it might never happen. So I figured I'd send it in under warranty and force the issue and make them address it somehow as I was getting increasingly annoyed by the problem.

Sure enough - voila - fix arrives.

If my k3 comes back in one piece and functions perfectly in every other way (like it did when I sent in it), I'll be happy with no regrets.
Not a whole lot to photograph around here right now, anyway.
Still have my K20D if that changes...
Cheers,
Forum: Pentax K-3 03-08-2014, 11:42 AM  
K-3 Power-on issue
Posted By dbh
Replies: 141
Views: 17,253
This is good news. Obviously Pentax found a way to solve this with a f/w update. Hopefully, when my camera comes back that's all they had to do to it, too! If they are on the ball there at the service centre, they'll flash it, test it, and ship it back pronto! They have had it nearly 3 weeks and I've missed it.
Forum: Pentax K-3 03-04-2014, 02:24 PM  
K-3 Power-on issue
Posted By dbh
Replies: 141
Views: 17,253
K-3 + D-BG5 has been with Pentax service for 2 weeks now. No word from them at all. No updates, estimates, status reports, nothing. Apparently, the only time I will learn anything about my camera is when it shows up back. In 4-6 wks.
I'm wondering has anyone else had their power-on issue fixed?
Forum: Pentax K-3 02-24-2014, 08:51 AM  
K-3 Power-on issue
Posted By dbh
Replies: 141
Views: 17,253
Sorry to hear of another person with this issue. I wish I had sent mine in earlier. While I'm still not convinced it can't be solved with a work-around in firmware, if Pentax never hears about it from customers, and since their QC measures can't seem to sniff it out, nothing would ever be done by them to address this on their own so I'm glad to hear you sent it in for warranty repair.
I'm sure Pentax will stand behind their warranty. However, I'm not so sure they will 'fess up to an inherent design flaw, systemic production fault, or known common problem and issue a recall or warranty extension like you sometimes see with cars and motorcycles.
Obviously everyone who never uses the battery grip will never experience this even if their K-3 is affected. So it's therefore automatically not a common issue. Even if you had no intention of buying a grip, but had heard about this potential problem and wanted to test for it while still in the store, it's a bit of finicky thing to reproduce (2 batteries, 20 min wait, etc.) so many possibly faulty cameras will be out there that Pentax will never need to deal with. So don't hold your breath while waiting for a full disclosure from them.

I've never had to make a warranty claim with Pentax and I've got lots of their gear, including 3 SDM lenses. But I hope this experience turns out well. I've learned a lesson, too: if you discover a problem, don't wait around for a f/w solution! One may never come if everyone does this and Pentax doesn't learn of the problem and feel a need to address it with returns flooding in. Also, if I had done this within the 28-day return period, I would not have had to wait for the fix, either.

While I rarely fall victim to this, I also see the wisdom in waiting a while before buying something newly introduced. Sometimes it's better to wait a year and get it cheaper and thoroughly debugged. However, I waited too long to get a K-01 and then missed out on the discontinuation fire sale, too.

Anyways, my K-3 will come back eventually. Hopefully fixed. Ideally with a detailed explanation of what was wrong. As I said before, I will report back here.
Good luck with yours...
Forum: Pentax K-3 02-19-2014, 09:24 AM  
K-3 Power-on issue
Posted By dbh
Replies: 141
Views: 17,253
Here's an update on my power-on issue. I got a replacement D-BG5 grip from the latest batch received by my local Pentax dealer. It did not solve the problem. Since it now appears that the fault lies with the K-3 I decided to send it and the grip into Pentax for them to fix the problem under warranty. I was told to expect it back in 6-8 weeks. :(
That should be the end of it for me. I will report back either way. Hopefully when it comes back fixed, an explanation will be included.
Forum: Post Your Photos! 02-11-2014, 07:46 AM  
Night Moon and aurora
Posted By dbh
Replies: 32
Views: 1,536
Beautiful! And well captured! Thanks for sharing these.
Forum: Pentax K-3 02-05-2014, 11:21 AM  
What the switchable AA filter needs to become truly useful is ...
Posted By dbh
Replies: 17
Views: 1,979
Wonder what happens when it is on along with exposure bracketing.
Forum: Pentax K-3 02-05-2014, 09:14 AM  
New firmware v 1.02
Posted By dbh
Replies: 116
Views: 17,143
Just an FYI - the file I got (and installed last night) from the Russian site yesterday is byte-for-byte identical to the one I downloaded from the Japanese site this morning.
Forum: Pentax K-3 02-04-2014, 06:37 PM  
K-3 Power-on issue
Posted By dbh
Replies: 141
Views: 17,253
No change to my power-on problem with the new firmware either.
Forum: Pentax K-3 01-21-2014, 11:01 AM  
K-3 Power-on issue
Posted By dbh
Replies: 141
Views: 17,253
I've never had the problem when using only one battery, regardless of where it was.

From Neil959's post, it appears that as long as at least one of the pair is a Ricoh-Pentax battery you can get the problem. So they both would have to be something else.
I'm thinking about buying a couple 3rd-party batteries just to see if I can replicate Neil959's result. They're cheaper and usually crappier but may be worthwhile if they solve this, admittedly minor, annoyance.
Forum: Pentax K-3 01-18-2014, 03:48 PM  
K-3 Power-on issue
Posted By dbh
Replies: 141
Views: 17,253
Turns out both of my "old" K5 batteries were also Pentax-Ricoh Imaging vintage also so no joy there. I was surprised and disappointed. I hope it does turn out to be the batteries as that should be addressable in firmware imho.
Forum: Pentax K-3 01-17-2014, 04:25 PM  
K-3 Power-on issue
Posted By dbh
Replies: 141
Views: 17,253
This is going to be one of the first things I try when I get home - I have exactly 2 batteries from the K-5iis which (hopefully) are both the older type. Be great if this turns out to be it! fingers crossed...
Forum: Pentax K-3 12-21-2013, 12:02 AM  
K-3 Power-on issue
Posted By dbh
Replies: 141
Views: 17,253
OK, I tried this just now. Grip attached, powered up with full batteries in both grip and body. BTW, my new work-around the power-on problem is to first release the grip battery slightly - power on the camera - power it off - push in the battery door - power up again. Works every time and lets me use both batteries. Back to the test...
Lens DA*16-50mm f2.8 SDM Built-in mic - all the defaults. (Haven't used the video recording functions before!)
Recorded 1'01" of full HD 30P onto a new Kingston 64GB Ultimate memory card without issue. Played it back right away perfectly. :confused:

Thoughts: possibly you had a bad SD card? What video mode were you trying to use? Anything else I should try to see if I can duplicate your lock-up?
Forum: Post Your Photos! 12-20-2013, 08:05 AM  
Machinery Machine Shop
Posted By dbh
Replies: 12
Views: 815
This thread started off great!
And then it improved.
Thanks for sharing jay08.
Search took 0.01 seconds | Showing results 1 to 25 of 300

 
Forum Jump


All times are GMT -7. The time now is 02:39 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top