Forgot Password
Pentax Camera Forums Home
 

Showing results 1 to 4 of 4 Search:
Forum: Troubleshooting and Beginner Help 03-07-2015, 09:27 AM  
Pentax ME Super Advance Lever Misfire
Posted By freefall
Replies: 9
Views: 1,435
At the moment, I have 9 film cameras not including the Super. K1000 SE brown is my favorite. So I'll just sell this one. It's in fantastic condition, it's too bad.
Forum: Troubleshooting and Beginner Help 03-05-2015, 09:22 PM  
Pentax ME Super Advance Lever Misfire
Posted By freefall
Replies: 9
Views: 1,435
I contacted Eric, but I wasn't looking to spend 3x the amount on a repair as I did on the camera. Looks like it's going on for parts. Thank you for the replies.
Forum: Troubleshooting and Beginner Help 03-05-2015, 09:12 PM  
Pentax ME Super Advance Lever Misfire
Posted By freefall
Replies: 9
Views: 1,435
There's nothing I can do to fix it? Is it a mechanical problem? Is it gummed up seals?
Forum: Troubleshooting and Beginner Help 03-05-2015, 07:53 PM  
Pentax ME Super Advance Lever Misfire
Posted By freefall
Replies: 9
Views: 1,435
I have an interesting situation, and whether or not it's common, I'm not sure. But my problem is that it's gotten to a point where I can pull the advance lever, and it goes all the way and pulls the shutter up with it, but then proceeds to let the shutter go when I let the wind lever go. The shutter button is pretty much useless at this point, because the shutter releases before I even have a chance to press the button. I don't know if the shutter is actually firing, or just opening and closing. The shutter speed changes based on how slowly I release the advance lever.

When I got the camera, I could pull the advance lever, (I don't know if it pulled the shutter up or not, I don't think so) and then release it, and it wouldn't do anything, nor would the shutter button. It would just crank, then I'd release it, and I could just crank it again. I felt little resistance. This was before some tinkering I shouldn't have done.

I've gone on a film craze this week, I think I've ordered ~6 cameras. I love getting them and then figuring out how they work. I would really appreciate any help, as this is the only one I haven't been able to fix. Thanks!
Search took 0.01 seconds | Showing results 1 to 4 of 4

 
Forum Jump


All times are GMT -7. The time now is 11:55 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top