Forgot Password
Pentax Camera Forums Home
 

Showing results 1 to 4 of 4 Search:
Forum: Pentax K-3 11-28-2013, 12:34 AM  
Buying overseas
Posted By Clive Washington
Replies: 1
Views: 649
Not sure if this is the right place to ask this question. Anyway.

I'm going to the USA in January and with the exchange rate I can save about 250 if I buy a K3 over there. What will be the situation for support? I've heard rumours that some companies consider this to be 'grey importing' and will not support/repair a product bought in another country. However I bought my first DSLR (a *ist DS) in the USA with no trouble. Not sure how much to worry about this as I've never had to have a camera repaired. Anyone got any experience of this area?
Forum: Flashes, Lighting, and Studio 11-27-2013, 12:39 AM  
Sigma wireless flash doesn't - help!
Posted By Clive Washington
Replies: 6
Views: 989
Well I spent 2 hours last night trying to get decent results and I couldn't even get proper sync, it kept firing on the preflash, so no exposure. The one off-camera mode that works fairly reliably is using a sync cable. This gives a good result when the flash is in TTL mode and the camera is in any mode - oddly even full manual! So I guess the flash is doing the exposure calculations. The problem is that there are so many combinations of trigger, camera mode, flash mode etc that you really don't know what's been designed to work with what. (If anything. I'm having a wish-I-had brought-a-nikon-30-years-ago moment, do I get booted for that?).

So I'm baling out of this, and have ordered one of the low-cost wireless triggers off ebay. This should, at least, ensure that I don't get preflash trigger problems (I hope!) and I can adjust the exposure through the aperture and film speed.
Forum: Flashes, Lighting, and Studio 11-24-2013, 02:02 AM  
Sigma wireless flash doesn't - help!
Posted By Clive Washington
Replies: 6
Views: 989
OK, I tried this - thanks - it did at least fire the flash in sync although the shot was about 3 stops underexposed, even in P mode, but I could get a decent exposure by increasing the ISO to 800. Using K5, not tried the K20D yet.

Last night I was doing some on-camera shooting with this flash and my K20D and all the shots were underexposed, switched to the K5 and they were all fine on the same settings. So there may be an issue with the TTL level communication. In the long run buying a Pentax flash, at twice the price, may be one fix (ugh).

Not had time to read all the links yet, will plough through those this evening!
Forum: Flashes, Lighting, and Studio 11-23-2013, 03:36 AM  
Sigma wireless flash doesn't - help!
Posted By Clive Washington
Replies: 6
Views: 989
I'm trying to use my Sigma EF530DG Super flash wirelessly, off camera, with my K20D and K5. Basically, the flash doesn't fire.

I'm fairly confident I have the simple stuff right - both the flash and camera are in wireless mode. Both are using CH1 which seems to be the default - although I have gone through the process of programming the flash on-camera as I know is required.

The flash will fire off-camera in simple slave mode - but of course it fires on the preflash so I don't get an exposure!

A couple of clues.. I know my camera uses CH1, as it displays this on turn-on. But if I set the flash manually to CH2 then attach it to the camera to program it, the programming doesn't change the flash to CH1. So something is up there.

Second, the flash display constantly has a "P" where the group number should be. I know that group number is used in Nikon wireless but it doesn't seem to be a Pentax option. Is this where the problem lies?

Problem is identical for K20D and K5, and all other on-camera flash modes work faultlessly, so I don't think I have a hardware problem. And all firmware is fairly recent.

Thanks for any help!
Search took 0.00 seconds | Showing results 1 to 4 of 4

 
Forum Jump


All times are GMT -7. The time now is 10:14 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top