Forgot Password
Pentax Camera Forums Home
 

Showing results 1 to 1 of 1 Search:
Forum: Pentax K-3 02-26-2016, 12:45 AM  
K-3 II + Manual Lens + Live View + Green Button = ???
Posted By Auzzie-Phoenix
Replies: 43
Views: 6,578
Reviving thread:

Testing my K-3II with several lenses yielded these results-

1.) FA Lens set to a physical aperture on ring: Green button works fine in LV.
2.) M 28 f/2.8: Green button works in LV.
3.) Super Takumar 50mm f/1.4 with pentax m42 to k adapter: Green button does NOT function in LV.

This leads me to believe that yes, not having electrical contact on the K-3II does create this issue in live view with some lenses, and probably most if not all M42 or older lenses. I have a K-50 as well. Green button in Live View works with all lenses regardless of contact or not. However on the K-50 and more than likely the K-30 as well, the older M42 lenses will not meter with green button in viewfinder mode, which is the opposite effect from the K-3II.

I would like to see if the K-30 behaves like the K-50, or like the K-3II. This would be quite interesting. Especially if someone made a listing of the quirks for each camera's green button behavior as some form of spreadsheet layout with an X under corresponding behavior box. Camera name: Live View Works: Viewfinder mode works. Put x under both if both work.
Search took 0.00 seconds | Showing results 1 to 1 of 1

 
Forum Jump


All times are GMT -7. The time now is 10:53 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top