Forgot Password
Pentax Camera Forums Home
 
Log in or register to remove ads.

Showing results 1 to 7 of 7 Search:
Forum: Pentax Medium Format 11-15-2011, 07:54 AM  
Pentax 67 TTL prism meter window not visible
Posted By vmixer
Replies: 8
Views: 3,420
Thanks for the info. re: the non-TTL prism. Agreed; it will be good to have both (I have two bodies and don't want to always have to have the waist level mounted on one).
Forum: Pentax Medium Format 11-15-2011, 07:32 AM  
Pentax 67 TTL prism meter window not visible
Posted By vmixer
Replies: 8
Views: 3,420
Thanks MysteryOnion -- sounds like a job for Mr. Hendrickson... I decided to get a non-TTL prism to go along with this one (and for times when I want 100% coverage). Once it arrives I'll likely send it off to him. Thanks for the help!

--Geoff
Forum: Pentax Medium Format 11-07-2011, 07:46 PM  
Pentax 67 TTL prism meter window not visible
Posted By vmixer
Replies: 8
Views: 3,420
Thanks gus, good to know I'm not the only one to ever experience this. I just gave it a gentle shake at diff. angles but no luck. I'm thinking of replacing it with another (used in good condition) and then sending this one off for diagnosis/repair.

Thanks,
--Geoff
Forum: Pentax Medium Format 11-04-2011, 10:22 PM  
Pentax 67 TTL prism meter window not visible
Posted By vmixer
Replies: 8
Views: 3,420
Thanks Dark_Mist, I figured as much. I have the waist-level finder as well and am fine with using a handheld meter until I find out what's up with the TTL. Will report back...
Forum: Pentax Medium Format 11-04-2011, 10:16 AM  
Pentax 67 TTL prism meter window not visible
Posted By vmixer
Replies: 8
Views: 3,420
Hi,

I can't see the little white window with the match needle in the viewfinder of my P67's TTL metering prism anymore. It was previously working fine (this behavior started following a spill my whole kit took off of the kitchen counter at the hands of a 2-year-old :)). It's not visibly damaged (no dents) and I'm now trying to use it with a different, newer body.

If I haven't used it in awhile, and I un-mount/re-mount everything in the correct order (as according to the manual) I can see the window and the meter will work normally for like 1 or 2 shots but then mysteriously disappears and I can't see the meter window whether the meter's mounted on the body or not. I imagine it's just plain "busted" (technical term) but thought I would see if anyone had seen this before. I've done the usual: thoroughly cleaned the contacts on the body/prism and made sure my body's aperture coupling chain isn't broken, etc.

Thanks,
--Geoff
Forum: Welcomes and Introductions 09-30-2011, 03:50 PM  
Greetings all...
Posted By vmixer
Replies: 3
Views: 651
Thanks, it's a pleasure to use as well. I just picked up the first roll I ran through it and everything seems to be working well. I haven't shot 35mm (film) in awhile and it's proving a nice change of pace from digital and 6x7 medium format. I have a feeling this won't be my last Pentax body...
Forum: Welcomes and Introductions 09-30-2011, 01:33 PM  
Greetings all...
Posted By vmixer
Replies: 3
Views: 651
Hi,

New forum member here. Have been a Pentax fan and 67 shooter for many years. Bought a couple of M42 lenses a few years ago to use on my DSLR with an adapter but only recently (Wed.!) acquired my first 35mm Pentax SLR, a beautiful black SPII from KEH in "bargain" condition (could've fooled me, it had just the amount of honest brassing I was hoping for!).



Really excited to learn from everyone here.

Best,
--Geoff
Search took 0.00 seconds | Showing results 1 to 7 of 7

 
Forum Jump


All times are GMT -7. The time now is 01:04 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top