Forgot Password
Pentax Camera Forums Home
 

Showing results 1 to 2 of 2 Search:
Forum: Pentax K-5 07-08-2013, 11:00 AM  
Pentax K5 locks up - return to Pentax or can it be fixed?
Posted By jedentagberlin
Replies: 4
Views: 1,569
Dear forum, my question first:

Should I return my Pentax K5 for a refund or a new camera?

Problem: My Pentax K5, bought brand new in February 2013, occasionally shows the lock-up problem discussed in many forums.
Either the mirror hangs and I cannot continue shooting or the LCD goes on, even if I turn off the camera, and I cannot shoot. Only taking out the battery solves this issue.

Last time the camera continued shooting even when I released the button. I turned it off, took out the battery and put it back in, but the camera continued to behave strangely.

It had the original Pentax battery installed and the latest firmware.

I brought it to the repair service (Foto März in Berlin) but after a week I only got it back with seemingly nothing fixed. I had hopes they would change the mainboard or whatever causes the problem. But since they could not reproduce the flaw, they just put the firmware on it (superfluous since the latest was running), "preemptively checked electronic parts" and set it back.

Now: Can this flaw be fixed at all or should I a) send it to the seller and get my money back, or b) send it to Pentax in order to get a new body?

I do like the K5 but I'm disappointed that I had to send it in twice since I bought it _brand new_. The first time for front focus, the second time for lock-ups.

Same thing with my K10D some years ago. I had to have it repaired for an askew viewfinder.

I might have had it with Pentax, really!

Are there any other users with the lock-up problem and how has it been fixed?

Thank you and best regards from Berlin
Forum: Pentax DSLR Discussion 11-02-2007, 02:48 PM  
K10D - image is consistently rotated?
Posted By jedentagberlin
Replies: 19
Views: 5,608
Just wanted to mention that I have the same problems with my brand-new K10D. Askew horizon on most of my pictures although I carefully level them in the viewfinder. On a table, the pictures come out correct, so it's not the sensor.
But it is neither my inability to take pictures: I have made perfectly leveled photos through the viewfinder of my Mz5n (ZX5n), even without a tripod. Nor do I have two differently long legs (honestly, that was a possible reason I read for the askew pictures).
I exchanged my brand-new K10D after two weeks in the shop for another one. Same issues. I couldn't believe it! This kind of error with an almost 1.000 Euro gear!!!
Instead of changing it for a third camera, I had it send to Pentax. Hopefully they fix the thing.
If not, I'll demand my money back and that was it for me and digital photography. At least with Pentax.
Search took 0.00 seconds | Showing results 1 to 2 of 2

 
Forum Jump


All times are GMT -7. The time now is 02:40 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top