Forgot Password
Pentax Camera Forums Home
 

Showing results 1 to 4 of 4 Search:
Forum: Troubleshooting and Beginner Help 09-06-2014, 02:02 PM  
K-5 - Mirror doesn't fire, says battery depleted.
Posted By IanAntonio
Replies: 21
Views: 2,793
This is really interesting. The "battery depleted" issue has affected my k5 too. She has a shutter count of just uver 37K.The first time it happened factory reset set her straight. About two weeks after it happened again but factory reset didn't help. A bit of research produced many responses on the topic albeit from pretty much the same forums. Possible solutions ranged from sending her in for repair (out of the question since warranty up), replacing motherboard or the like, substituting battery, leaving the battery out overnight, discharging the battery with a 12 volt car bulb then recharging and replacing it, to pressing LV button in quick succession. The combination that got my baby working again, just as I pretty much decided to get the K3, was removing battery for about 2 hours, removing the lens and flicking the mirror 4 times, then giving her three firm slaps on the underside with 4 fingers. Now she's all fired up again, but who know how long before she gets moody again, or how long she'll stay, now that I have eyes for K3.
Forum: Pentax K-5 10-18-2012, 12:19 PM  
HELP - F-- Error (Blinking) with new SMC Pentax-M 50mm F1.7
Posted By IanAntonio
Replies: 6
Views: 6,225
Parallax, thanks a bunch! It worked. I just set the "Using Aperture Ring" to "permitted", in settings > C > 4 > 27. One of the reasons I bought the K5 in the first place is because it allows me to use these old lenses, and start to pretend to look like a Pro. Loving the sharpness, and the pleasant surprise on my quest into the secret realms of manual photography, is that that little red focus indicator light is a great help when it comes to telling me where the "focus sweet spot" is.

Thanks again.
Forum: Pentax K-5 10-18-2012, 10:11 AM  
HELP - F-- Error (Blinking) with new SMC Pentax-M 50mm F1.7
Posted By IanAntonio
Replies: 6
Views: 6,225
Hello everyone, I was so excited to get my brand new second hand "SMC Pentax-M 50mm F1.7" based on the great reviews. Sadly the only thing I see when I attach it to my new K5 if a blinking "F--". the lens appears to be in good order but for some reason my K5 refuses to take a pic. when its on. All is still well with the kit lens (18-55), but I was soooo looking fwd to making some Bokeh.

I'd hate to have to return the lens, please help.:o

Ian
Forum: Welcomes and Introductions 08-02-2012, 01:06 AM  
Hello
Posted By IanAntonio
Replies: 1
Views: 403
:lol: Hi everyone..
Search took 0.00 seconds | Showing results 1 to 4 of 4

 
Forum Jump


All times are GMT -7. The time now is 09:37 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top