Forgot Password
Pentax Camera Forums Home
 

Showing results 1 to 12 of 12 Search:
Forum: Pentax SLR Lens Discussion 05-07-2009, 07:45 AM  
portrait pictures with 21 ltd
Posted By adhall82
Replies: 7
Views: 2,026
I think it depends on the style/look you are going for. I don't have the Pentax 21, but have a Sigma 20 1.8 and actually will be doing my first model shoot with it later today, along with the FA50 1.4... I'll try to post some shots with the 20 later.

I intend to get "portraits" with it, although it wouldn't really be conventional portraiture.
Forum: Pentax SLR Lens Discussion 05-07-2009, 07:24 AM  
Sigma 20 1.8, nails close focus, back-focuses at a distance. What to do.
Posted By adhall82
Replies: 1
Views: 1,996
All in all, I really like this lens. Despite reviews to the contrary, I have found it to be respectably sharp wide open, as long as the focus is nailed. But, it does consistently back-focus at any distance longer than arms length. Closer, it nails it. I'm inclined to believe it has more to do with the K20d's not-so-stellar AF system, as apposed to the lens itself...

My dilemma is this; do I try to correct the auto focus for subjects farther away, likely causing forward focus on close subjects, or just say eff it, and learn to manually focus better? The latter being what I have done mostly to this point.

I feel like I know the best answer here, but would like some others' input as well...
Forum: Pentax SLR Lens Discussion 05-07-2009, 06:56 AM  
I want Pentax FAST wide angle primes.
Posted By adhall82
Replies: 36
Views: 9,492
Check out the sigmas...
Forum: Photographic Industry and Professionals 05-07-2009, 06:49 AM  
KEH.com Scam or Not?
Posted By adhall82
Replies: 38
Views: 19,089
I would say that they tend to have good prices and ratings, like others have noted, tend to be understated. BUT I had a crappy customer service experience with them when I had to return a camera that had a sensor issue. It took 2 or 3 months and many phone calls before I got my credit back. My friend, who has been using them for years and recommended them to me, also recently started having some crappy experiences with return items. Sounds like they have been the bomb in the past, but have started to slip customer service wise... but maybe I had bad luck and am one of the exceptions. It happens I guess.
Forum: Pentax SLR Lens Discussion 04-24-2009, 07:31 AM  
Poll: Looking for 16-45mm and market price weirdness
Posted By adhall82
Replies: 9
Views: 2,126
I got a new one on Adorama recently for just under $300 (US) shipped. Seems to be excellent to me... and from the research I did, I didn't come across reports of bad copies, unlike the 16-50 DA*...
Forum: Pentax SLR Lens Discussion 04-14-2009, 08:12 AM  
FA 50 1.4 on K20d... 1.4-2 not a full stop?
Posted By adhall82
Replies: 19
Views: 4,290
Thanks Andrew. So after review of MANY shots to test this issue, it seems that it could possibly be the light fall off/vignetting you are speaking of, but indeed more extreme on my copy; to the point where it appears I underexposed a shot by a stop, and then lightly dodged a small circle in the center of the frame. Oh well, it really is a great lens other than this, it's just a bummer I can't seem to take full advantage of it's intended speed. Maybe I'll come across a better copy down the road. I don't think I feel like sending it back again...

Thanks again for all your input and help.
Forum: Pentax SLR Lens Discussion 04-13-2009, 04:13 PM  
FA 50 1.4 on K20d... 1.4-2 not a full stop?
Posted By adhall82
Replies: 19
Views: 4,290
bump... any one else with k20d and 50 1.4?
Forum: Pentax SLR Lens Discussion 04-13-2009, 04:09 PM  
FA 50 1.4 on K20d... 1.4-2 not a full stop?
Posted By adhall82
Replies: 19
Views: 4,290
No, it's definitely an entire image under-exposure, not a vignetting... that I wouldn't mind so much. But thanks for the input. It basically just seems that it's effectively a 1.8, not a 1.4...
Forum: Pentax SLR Lens Discussion 04-10-2009, 10:11 AM  
FA 50 1.4 on K20d... 1.4-2 not a full stop?
Posted By adhall82
Replies: 19
Views: 4,290
Hmmm, well, with the lens off, wide open I can't see any shutter blades, so that seems right.. Manual operation on my FA also only allows one click from 1.4 to 2, but when I tested like you said, manual operation using the green button to meter, it only meters 1/3 stop difference.

The only other lens I have right now is the 16-45 f4. Tested that in third stops from 4-5.6 and it works like it should.

This is really weird. I find it hard to imagine that no one else has ever seen this before and I happened to get the same problem on 2 consecutive lenses. Seems like there may be an issue with the K20D and fa 50 1.4 relationship. What body are you shooting with?
Forum: Pentax SLR Lens Discussion 04-10-2009, 08:14 AM  
FA 50 1.4 on K20d... 1.4-2 not a full stop?
Posted By adhall82
Replies: 19
Views: 4,290
Well, right, that's what it's supposed to do... and mine does too, in aperture OR shutter priority (automatically changing aperture), but in the 1.4-1.8 range(or 1.7 if in half stops) the auto exposure doesn't stay consistent between shots. If I'm in manual and keep the shutter speed the same between 1.4 to 1.8, the exposure is the same, but should be at least a half stop difference....

I guess I'm missing what you're trying to say.
Forum: Pentax SLR Lens Discussion 04-10-2009, 07:06 AM  
FA 50 1.4 on K20d... 1.4-2 not a full stop?
Posted By adhall82
Replies: 19
Views: 4,290
I posted this in the "newbie" forum, but without much response. I'm a not so much a newbie to photography, but just switched over to Pentax...

I just recently switched to Pentax with the K20d, and got a fa 50 1.4.
After a couple days of shooting, I noticed that 1.4 didn't seem to be giving me a full stop more of light than 2.0. I did some "testing" with various static objects and in different lighting scenarios; in manual, keeping a fixed shutter speed but adjusting the aperture in thirds each shot 1.4>1.6>1.8>2.0. Comparing the histograms (although it's obvious in the picture) on the camera or in Lightroom is showing no change from 1.4>1.8. I thought the aperture to be defective, so I placed a return order with B&H.

Got the new lens, but it acts exactly the same. So it doesn't seem to be a defective lens, unless I just happened to get two in a row with the same defect. Could it have to do with being a film era lens on a digital crop sensor? Has anyone else noticed this?
Forum: Pentax SLR Lens Discussion 04-09-2009, 01:02 PM  
FA 50 1.4 on K20d... 1.4-2 not a full stop?
Posted By adhall82
Replies: 19
Views: 4,290
I just recently switched to Pentax with the K20d, and got a fa 50 1.4.
After a couple days of shooting, I noticed that 1.4 didn't seem to be giving me a full stop more of light than 2.0. I did some "testing" with various static objects and in different lighting scenarios; in manual, keeping a fixed shutter speed but adjusting the aperture in thirds each shot 1.4>1.6>1.8>2.0. Comparing the histograms (although it's obvious in the picture) on the camera or in Lightroom is showing no change from 1.4>1.8. I thought the aperture to be defective, so I placed a return order with B&H.

Got the new lens, but it acts exactly the same. So it doesn't seem to be a defective lens, unless I just happened to get two in a row with the same defect. Could it have to do with being a film era lens on a digital crop sensor? Has anyone else noticed this?
Search took 0.00 seconds | Showing results 1 to 12 of 12

 
Forum Jump


All times are GMT -7. The time now is 02:32 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top