Forgot Password
Pentax Camera Forums Home
 

Showing results 1 to 3 of 3 Search:
Forum: Pentax DSLR Discussion 12-13-2015, 07:47 AM  
Anti Pentax bias
Posted By K1000x
Replies: 21
Views: 4,052















You Tube



I know it's been said before, but I can't look at Northrup and not think about Billy Bob Thornton's Lorne Malvo from Season One of 'Fargo'!
That was really informative video , but I don't think anyone would look down on Pentax because of it. He said clearly at the start that he would be using a second hand $100 Pentax K200 with an 18-55mm against a new $3000 Nikon D810 with a $1000 Sigma 24-105mm lens.
She was also shooting at ISO 64 on the Nikon as opposed to ISO 100 on the Pentax, but using post processing, he matched the results of the Nikon!
I suppose what he didn't say when comparing the original shots that the K200's original images were less sharp not because it was a poor camera, but a 10.2mp APS sensor being pitted against a full frame 36mp sensor with a superior lens and a lower ISO!

What really hurts Pentax are ill informed articles, like the equipment ratings in 'What Digital Camera' that rates the K3 below the K5II (what planet are they living on?) & they just don't promote their cameras as well as Canon & Nikon.
Forum: Pentax Film SLR Discussion 07-23-2015, 09:12 AM  
Pentax Spotmatic light meter issue
Posted By K1000x
Replies: 24
Views: 32,739
I know this is an old thread, but before resorting to opening up your camera, try this.
I bought a SPII with a 55mm f1.8 SMC Takumar lens pretty cheaply off ebay recently. Everything was fine apart from the light meter, which was stuck in the centre after replacing the spent battery with a new AG3. I opened the lens up to f1.8, activated the meter and shone one of those bright white LCD torches into it for a second.
Seconds later it was working & after testing it against the meter on my K1000 its giving accurate readings.
Hopefully this will work for others with the same problem.
Forum: Troubleshooting and Beginner Help 12-04-2014, 11:41 PM  
K-X autofocus not working
Posted By K1000x
Replies: 17
Views: 5,544
I've had the same issue as you a couple of times, but it was 100% my fault & was easily fixed.
My problems came from buying second hand vintage lenses & in my keenness to try them out, not checking for dirt on the lens, which got into
the body of the camera through the autofocus screw and stopped it working.

Previous posters have mentioned contact cleaner, but to be more precise, the thing you need is electronic cleaning solvent - isopropyl alcohol Isopropyl Alcohol 400ml | Maplin. Carefully spray a little into the autofocus screw & the MF/AF switch, then wait until the smell of the alcohol has completely gone.

This means the alcohol will have completely evaporated, taking the dirt with it.
After this, the autofocus should be back to normal.

If it still doesn't work and you decide to desert Pentax, I'd buy Nikon rather than Canon!
Search took 0.00 seconds | Showing results 1 to 3 of 3

 
Forum Jump


All times are GMT -7. The time now is 01:23 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top